Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 39
  1. #1

    '99 XPL RPM Question

    Hi All,

    I have a bit of a weird issue with my boat at the moment. Not sure how long its been doing it....

    When I give it full throttle it doesn't always rev up to 7200rpm. Alot of the time it will scream up to 6200rpm and then slowly build to 7200rpm. If I have been out for an hour or so giving it a hard time then it generally hits full rpm more often and easily.

    Got any ideas? I generally only notice it when im on the river as out in the sea Its not calm enough for me to hit that high rpm. However for taking off it would be handy...

    Ski engine wise is stock, has replaced lines and cleaned fuel selector and I pulled the carbs off and apart and cleaned them all not long ago.

    Any ideas?

    Cheers,


    Chris


  2. #2
    Kidd800XP's Avatar
    Join Date
    Apr 2008
    Location
    Piedmont,Al
    Posts
    343
    When was the last time the spark plugs were changed?

  3. #3
    Within a few months.

    Worth a try? I highly doubt it....?

  4. #4
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    Quote Originally Posted by kidafa View Post
    When I give it full throttle it doesn't always rev up to 7200rpm. Alot of the time it will scream up to 6200rpm and then slowly build to 7200rpm.

    Ski engine wise is stock
    if your ski is stock, how is it able to turn 7200rpm? completely stock you should only turn 6900, maybe 7k.

    i believe the stock rev limiter is 7160 if i remember correctly. you are either way lean or have a cavitation problem.

  5. #5
    Ok 7200 might be an exaggeration. It deff pushes over 7000rpm but the stock rev limit has been upped a tiny bit by a PWC mechanic.

    I dont see how cavitating could affect this?

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    It sounds like your RAVES are intermittently not opening. Check your check valve under the carbs. You can spray carb cleaner through it and sometimes clear it out.

    Or, it could be a loose electrical connection at the solenoid valve.

  7. #7
    Quote Originally Posted by 96XPSS View Post
    It sounds like your RAVES are intermittently not opening. Check your check valve under the carbs. You can spray carb cleaner through it and sometimes clear it out.
    What is this "Check Valve" how do I check it? do I need to pull the carbs or whats the go?


    Quote Originally Posted by 96XPSS View Post
    Or, it could be a loose electrical connection at the solenoid valve.
    Is this the small solenoid that the hose that goes to the power valves?

  8. #8
    Kidd800XP's Avatar
    Join Date
    Apr 2008
    Location
    Piedmont,Al
    Posts
    343
    Quote Originally Posted by kidafa View Post
    What is this "Check Valve" how do I check it? do I need to pull the carbs or whats the go?

    It is under the carbs next to the pulse line.You dont have to pull the carbs to get to it. It only flows one way and sometimes they get stopped up.


    Is this the small solenoid that the hose that goes to the power valves?

    The line runs from under the carbs at that check valve to the solenoid and then to the raves.

    When was the last time the raves were cleaned?

  9. #9
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by kidafa View Post
    What is this "Check Valve" how do I check it? do I need to pull the carbs or whats the go?

    Trace the vacuum line to the RAVES. It loops under the engine and connects to the engine under the rear carb. No, don't pull the carbs.



    Is this the small solenoid that the hose that goes to the power valves?
    Yes. But only Yamahas have "powervalves"

    Kidd could be onto something too. If you haven't cleaned your "RAVES" lately the carbon buildup could be preventiing them from opening. I didn't mention this because one normally sticks, not both. And your 6200 means both aren't opening.

  10. #10
    So what is the check valve then mate?

    Yeah sorry get power valves and raves mixed up (got a yam motorcrosser :P)



    On the hose it will rev its guts out all the way up to 7 straight away?.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 XPL Buzzer Question
    By Porschephreak in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-21-2011, 08:41 PM
  2. 99 XPL upgrade question
    By badjoka in forum 2-Stroke Performance
    Replies: 10
    Last Post: 08-07-2010, 04:54 PM
  3. 99 xpl questions on racing
    By pyroguy1974 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-14-2008, 05:55 AM
  4. '99 XPL reaches RPM and Speed
    By jetcar123 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-01-2008, 03:02 PM
  5. 99 XPL closed course ski questions
    By redbull in forum 2-Stroke Performance
    Replies: 11
    Last Post: 12-06-2007, 08:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •