Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Oct 2009
    Location
    derbyshire
    Posts
    76

    99 xpl gauges goin mad?????

    from my previous posts... i was out riding when my ski died... kept blownig 15a fuses. to find the bendix had lost some teeth that had gone onto the mag and shorted out. after buyin replacing the bendix i got it back together i found that when the engine is running the rev counter and speedo are all over the place???
    checked all the earths.. they seems fine.
    Last edited by clownhands; 12-23-2009 at 04:03 PM.


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Did you confirm your stator wasn't fried when you had it apart? Did you clean out all the metal shavings inside the front cover too?

  3. #3

    Join Date
    Oct 2009
    Location
    derbyshire
    Posts
    76
    cleaned all the metal bits out from everwhere. the stator looked ok from what i could see, just a very slight discolouration but suppose that could mean its shot it???
    do the clocks work od the stator then??
    i'll get a new stator orderd

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Check the pics of the stator in this thread, it's on this page (4). It will help.

    http://www.greenhulk.net/forums/show...=stator&page=4

  5. #5
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Dude, I am not trying to flame you, but where in the world are you that guages are called "clocks"?

    Do you have ALL of the small ground wires hooked back up to the front cover?

  6. #6

    Join Date
    Oct 2009
    Location
    derbyshire
    Posts
    76
    looking at the pics in that link my stator is completly shot.. oh well was hoping to use it on boxing day but will just have to wait. cheers guys great help

  7. #7

    Join Date
    Oct 2009
    Location
    derbyshire
    Posts
    76
    ha ha im in sunny england, i'll remember to call them by the propper name next time!
    all the small grounds are on and tight.

  8. #8
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    It is not a big deal. I was just curious because I had never seen them referenced like that.

    At first I thought maybe you were riding in the Bermuda Triangle

  9. #9
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    I see they let the tard out today. way to make friends Andy.
    SHOOTER

  10. #10
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    LOL I thought the same thing.

    EDIT: This post was referring to Krunch. Shooter beat me to a post by one minute...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99' XPL aftermarket gear
    By redbull in forum 2-Stroke Performance
    Replies: 1
    Last Post: 09-17-2007, 06:46 PM
  2. Installing Wear Ring in 99 XPL
    By cws in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-29-2007, 08:10 PM
  3. 99 XPL lanyard problem
    By Duke in forum 2-Stroke Performance
    Replies: 9
    Last Post: 07-18-2007, 04:18 PM
  4. 98 xpl wear ring vs. 99+ xpl wear ring
    By JayZ in forum 2-Stroke Performance
    Replies: 9
    Last Post: 07-03-2007, 09:24 AM
  5. Removing Seat Strap - 99 XPL
    By hemicuda in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 03-12-2007, 03:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •