Results 1 to 10 of 10
  1. #1

    Join Date
    Jul 2005
    Location
    Indianapolis, IN
    Posts
    176

    not good please read!!!

    recently on the rxp i have been having some problems with a leak, (i will to edit in the posts later)

    this is what happened today:

    the hull was 3/10 full of water and i take off the intake grate

    water starts pouring from the 13mm hole

    then about 2 minutes later water starts coming down from the driveshaft/hull contact

    whats happening??




    anyway sorry about the little help guys, but please help me!!

    thanks


  2. #2
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,199
    +1
    51
    mine had a similar problem with the pump shoe. what year is yours? warranty?

  3. #3

    Join Date
    Jul 2005
    Location
    Indianapolis, IN
    Posts
    176
    no warrenty

    all stock 2005

  4. #4

    Join Date
    Jul 2005
    Location
    Indianapolis, IN
    Posts
    176
    the more i think about it, it might just be the pump support. the leak from driveshaft/hull contact seamed to get stronger as i applied force to the 4 pump mounting bolts....



    what do i do now? fiberglass repair shop?


    aldo, does the water coming from the 13 mm hole make it definite the pump shoe?

  5. #5
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    [QUOTE= ... also, does the water coming from the 13 mm hole make it definite the pump shoe?[/QUOTE]

    Water WILL drain from the forward grate hole when you remove the 13mm bolt.

    Likewise, water WILL enter the hull if the forward bolt departs the ski while riding.

  6. #6
    Isn`t the bottom half of the hull in 2 parts, inner and outer?
    the threaded insert for the front bolt is in the lower half, so wouldn`t you think that you have water in between the 2???...PR...

  7. #7
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    Quote Originally Posted by Pale Rider
    Isn`t the bottom half of the hull in 2 parts, inner and outer?
    the threaded insert for the front bolt is in the lower half, so wouldn`t you think that you have water in between the 2???...PR...
    On the old GTX hull there isn't two layers in that spot, one thick layer. I'm assuming it's the same way on the 4Tec's. All around the driveshaft tunnel is one layer, on the side of the ride plate is two layers with foam in between.

  8. #8

    Join Date
    Jul 2005
    Location
    Indianapolis, IN
    Posts
    176
    interesting

    if it's not the pump shoe thats great

    i put the 13 mm bolt back in the intake stoped leaking there but now it leaks through the driveshaft/hull contact area

  9. #9
    Quote Originally Posted by GTXX
    On the old GTX hull there isn't two layers in that spot, one thick layer. I'm assuming it's the same way on the 4Tec's. All around the driveshaft tunnel is one layer, on the side of the ride plate is two layers with foam in between.
    Hmmm, interesting, I can`t see the threaded bolt insert for the front bolt from inside the hull!?...PR...

  10. #10

    Join Date
    Jul 2005
    Location
    Indianapolis, IN
    Posts
    176
    Quote Originally Posted by Tiplickhahaha
    interesting

    if it's not the pump shoe thats great

    i put the 13 mm bolt back in the intake stoped leaking there but now it leaks through the driveshaft/hull contact area

    is this because of the carbon seal going bad?

    i noitced only when the level gets up to about the driveshaft level in the hell it starts leaking from the intake.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need more performance.....Please read not the usual.
    By bbanks in forum Yamaha PWC Performance (2-stroke)
    Replies: 47
    Last Post: 02-25-2009, 01:01 PM
  2. *** New Users FAQ :: PLEASE READ BEFORE POSTING ***
    By Shibby1485 in forum Site News & Suggestions
    Replies: 0
    Last Post: 03-21-2006, 03:47 PM
  3. Please Read............
    By xcduetester in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 12-26-2005, 07:05 PM
  4. aluminum wear ring (not good)
    By buddydoo in forum 4-Tec Performance
    Replies: 29
    Last Post: 11-07-2005, 08:15 PM
  5. 1300 hull crack...need advice please read
    By RXPNJ in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-28-2005, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •