Results 1 to 2 of 2

Thread: Yah, It runs!

  1. #1

    Join Date
    Aug 2009
    Location
    San Diego, CA
    Posts
    71

    Yah, It runs!

    So I finally got test my '93 VXR Pro. Yes on Christmas day my daughter and I went out for a ride at Mission Bay in San Diego. She has a '91 VXR that runs great. My VXR Pro had some neglected issues that the previous owner past onto me but for $300 bucks I couldn't pass it up. Anyway after doing the usual fixes Santa gave me a good running ski. This was the best Christmas gift I could ask for. Now that I have it running it's time for some paint and grapics!


  2. #2
    Appologizes for the last user title katz1002's Avatar
    Join Date
    Jun 2009
    Location
    Sadler
    Posts
    317
    Welcome to GreenHulk and congrats on your ski

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. High Idle After it runs a while
    By retro in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-14-2009, 06:37 PM
  2. It runs!
    By FTPPNET in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 05-28-2009, 09:20 PM
  3. Any way to test a XLT 1200 Gauge without it running?
    By nightrider05 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 03-02-2009, 07:30 PM
  4. Two test It runs max speed 63.4 GPS
    By sportman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 38
    Last Post: 04-03-2008, 11:40 PM
  5. Not sure if its running right?
    By zdowell in forum 2-Stroke Performance
    Replies: 0
    Last Post: 06-18-2007, 08:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •