Results 1 to 3 of 3
  1. #1

    1999 Polaris MSX Trim

    Just bought a 1050 MSX with 16 hours on it off Craigslist 0n 12-22-09. The trim indicator says it is moving up and down, but it's not. Any idea whats wrong. I did start the engine when I checked it.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Well, I can tell you the model isn't an MSX

    Maybe SLX

    Often the Trim motor gets rusted up inside the gearbox, and sometimes the problem is a corroded or broken electrical connection.

    Search in the Polaris Tech and General sections. Lots of info on testing, opening, and repairing trim motors.

  3. #3
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    Is the trim push rod connected at both ends? Is the plastic gear (attached to the motor) stripped or slipping on the push rod connection?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Polaris SLH trim
    By drwet in forum Polaris Open Discussion
    Replies: 3
    Last Post: 11-28-2011, 08:41 AM
  2. 1999 Polaris Genesis 1200 "Sleeper" project
    By SCXtrmSnwNWtr in forum Polaris Projects
    Replies: 23
    Last Post: 05-12-2007, 06:15 PM
  3. Polaris MSX 150 oil
    By Cobralyn in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-03-2007, 11:24 AM
  4. polaris msx 150 overboost prob
    By ln69bt in forum Polaris Open Discussion
    Replies: 19
    Last Post: 04-24-2007, 03:19 AM
  5. 1999 Polaris SLTH STARTING PROB!
    By bski224 in forum Polaris How To & FAQs
    Replies: 29
    Last Post: 02-04-2007, 10:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •