Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    low oil pressure

    coming up with warning code ps1520. Oil warning coming up.
    supercharger failed at 37hrs metal washers let go. have had engine apart little bit of scoring inside housing but nothing to indicate major failure .
    ski now has 120hrs the last 30 with rude 2 charger no problems at all until now. at idle sounds good give it a rev sounds good throttle response seems good after 30 sec run time goes into limp mode but oil levels are good any idea`s what could be wrong. i need help before the fire department is called in any input would be appreciated


  2. #2
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,069
    +1
    790
    Oil pumps or spun bearing.

    Make sure you find out so as to not cause damage that can not be fixed.
    .

  3. #3
    PEST!'s Avatar
    Join Date
    Jun 2008
    Location
    Rockledge Florida
    Posts
    768
    I would look at the oil pressure sensor connection and the sensor it self. Then if everything is good move on to putting a pressure gage on the engine to see if its actually low. I pick that order because I can check the sensor easier than rigging a gage but you get the idea..
    Verify the problem first then tear into things...IMHO

  4. #4
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    Is there also a strainer before the oil pump that could be filled with junk? (Diff to oil filter)

  5. #5
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    morten i wouldnt run the ski anymore till u find the problem. pest & waterfire have good info. what year is your ski?

    Quote Originally Posted by lolzer View Post
    Is there also a strainer before the oil pump that could be filled with junk? (Diff to oil filter)
    yes there are screens but if there blocked then you would have a BIG problem as there should be nothing in the motor that would cause a blockage like that.

  6. #6
    Quote Originally Posted by sportsterme View Post
    morten i wouldnt run the ski anymore till u find the problem. pest & waterfire have good info. what year is your sk


    yes there are screens but if there blocked then you would have a BIG problem as there should be nothing in the motor that would cause a blockage like that.

    2007 rxp

  7. #7
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Quote Originally Posted by morten View Post
    2007 rxp

    Im sending you the 2007 shop manual check your PM's

  8. #8
    Change out the oil senser under manifold seen that do it many times.You also could put a gauge on it to see if it is sensor or acually oil pressure problem.

  9. #9
    You did not lose a gear did you.If nI will beet its the sensor.

  10. #10
    thanks for the help guys
    just a faulty sensor managed to borrow one and all is good

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 GTX Limited low oil pressure
    By chuck2 in forum 4-Tec Performance
    Replies: 10
    Last Post: 09-20-2012, 12:35 PM
  2. Troubleshooting Low Oil Pressure
    By 05Limited in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-11-2009, 11:14 PM
  3. problem low oil pressure light
    By thegasman34 in forum Honda Open Discussion
    Replies: 1
    Last Post: 04-27-2009, 06:45 PM
  4. low oil pressure warning/buzzer
    By zone 5 in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-15-2008, 10:41 PM
  5. Low oil Pressure Sensor Threads
    By kc8lbn in forum Honda How To & FAQs
    Replies: 1
    Last Post: 03-12-2008, 08:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •