Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38

Thread: Head issue?

  1. #1

    Join Date
    May 2009
    Location
    Miami, Florida, United States
    Posts
    306
    +1
    4

    Head issue?

    So i pulled my head today to send it out to get milled...

    the piston tops are pretty caked up with crud. along with sand it looks like? could it be sand or just dried up deposits?

    is this normal? my plugs are caked up with oily globs as well.. the plugs only have a few hours on them.. is the ski running rich? help???

    I run Yamalube in it as well if that matters?

    MODS to engine
    RIVA FF xaust
    RIVA tuner
    RIVA F/A
    RIVA D plate


  2. #2
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,501
    +1
    619

    pics

    a few pics so the tuners and everyone could see and evaluate.

  3. #3
    Mike xsockguyx's Avatar
    Join Date
    Sep 2007
    Location
    NJ
    Posts
    1,744
    +1
    2
    Quote Originally Posted by flkeyzgp1300r View Post
    So i pulled my head today to send it out to get milled...

    the piston tops are pretty caked up with crud. along with sand it looks like? could it be sand or just dried up deposits?

    is this normal? my plugs are caked up with oily globs as well.. the plugs only have a few hours on them.. is the ski running rich? help???

    I run Yamalube in it as well if that matters?

    MODS to engine
    RIVA FF xaust
    RIVA tuner
    RIVA F/A
    RIVA D plate

    I'm guessing the RIva tuner is the EFI controller. What are the settings??

  4. #4

    Join Date
    May 2009
    Location
    Miami, Florida, United States
    Posts
    306
    +1
    4
    yes settings are what the paper called for.. i think they are 2 rich but i have a hard time seeing a difference when i adjust it..

  5. #5
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    for an 08 those tops dont look so good, Its hard to tell with the pictures but did you ever flip the ski? The color looks like muck like exhaust/water. hard to tell though without seeing it in person

  6. #6

    Join Date
    May 2009
    Location
    Miami, Florida, United States
    Posts
    306
    +1
    4
    I have only put 10 Hrs on it since bought from the dealer.. it was considered "NEW NEVER TITLED" from the dealer but had 40 hrs on it.. so i think the dealer beat the shit out of it.. should i just try to clean all of it off with a razor or scrapper or something? what about the left over dust and crumbs?

  7. #7
    32 Valves To Love! Racecar_Dave's Avatar
    Join Date
    Jul 2009
    Location
    Alum Creek
    Posts
    635
    +1
    2
    I wonder if you even need a controller at all, when I adjust mine you can feel and hear a difference in the settings.

    The pistons do look NAZTY, I have 80hrs on mine and they looked alot better than yours. IT does kinda look like a sand/carbon mixture. I would think you'd have to pop your pistons out to avoid scratching your walls. Hone the cylinders, install new rings, put it back together. I think that's going to be your cheapest option.

  8. #8
    "Hustler" Inkaddict's Avatar
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    4,712
    +1
    26
    Did you put washers on the head bolts after having the head milled? Crashard is rite.. Looks like ingested water...

  9. #9
    Quote Originally Posted by Inkaddict View Post
    Did you put washers on the head bolts after having the head milled? Crashard is rite.. Looks like ingested water...
    So i pulled my head today to send it out to get milled...
    1st post...

  10. #10

    Join Date
    May 2009
    Location
    Miami, Florida, United States
    Posts
    306
    +1
    4
    does it need washers after i get the head back?

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GTX 4-Tec 155 Head Issue (2004)
    By HoverRL in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-21-2014, 11:15 AM
  2. Oops - another head issue!
    By tchies in forum 4-Tec Performance
    Replies: 8
    Last Post: 01-08-2012, 07:17 PM
  3. Starter Issues - Way over my head
    By mrzippy in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 06-13-2010, 10:57 AM
  4. RXP Head Gasket Issue
    By Chaserxp215 in forum 4-Tec Performance
    Replies: 8
    Last Post: 01-03-2009, 07:02 PM
  5. Carbs Rebuilt, tops out at 55, and stripped head bolt issue..XLT1200
    By vjkevlar in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 08-06-2008, 01:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •