Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Feb 2007
    Location
    Chino,Calif.
    Posts
    45

    Oil on spark plugs!

    Changed my spark plugs and found my 2 and 3 cylinder plugs were dripping in oil!!! '04 RXP 229 hours. Stock engine with x-charger,#42's,4'' intake,14-19 solas. Last run about 2 months ago. Ran fine(71-72mph). Since then, added Fizzle external inter-cooler,thru hull exhaust,Riva Pro block-offs,15-20 solas. Have not tried it yet, but started it and it had a rough idle,like it was loaded up or rich. Cleaned the oil out and changed plugs and it sounded great. Idle was smooth and it revs clean. Just wondering where the oil came from. Started it 3 times and it sounds ok???? Phil


  2. #2
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    Quote Originally Posted by rxprsn View Post
    Changed my spark plugs and found my 2 and 3 cylinder plugs were dripping in oil!!! '04 RXP 229 hours. Stock engine with x-charger,#42's,4'' intake,14-19 solas. Last run about 2 months ago. Ran fine(71-72mph). Since then, added Fizzle external inter-cooler,thru hull exhaust,Riva Pro block-offs,15-20 solas. Have not tried it yet, but started it and it had a rough idle,like it was loaded up or rich. Cleaned the oil out and changed plugs and it sounded great. Idle was smooth and it revs clean. Just wondering where the oil came from. Started it 3 times and it sounds ok???? Phil

    it will only be from the tube seals i just had a quick look at the parts fiche it apears that you have to buy the tubes to get the seals some one correct me if im wrong there number 29 in the picture i have supplyed you will also need a new rocker cover gasket.. all parts can be purchased from jerry through his online oem store...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	tube seal.jpg 
Views:	100 
Size:	88.5 KB 
ID:	166125  
    Last edited by westy; 01-02-2010 at 05:09 AM. Reason: added text

  3. #3
    PEST!'s Avatar
    Join Date
    Jun 2008
    Location
    Rockledge Florida
    Posts
    768
    #8 is the seal. If I was going to replace them I might also look at getting new valves. The 04's have been known to drop valves. But if you are careful you can replace just the seals without removing the head..

  4. #4
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    Quote Originally Posted by PEST! View Post
    #8 is the seal. If I was going to replace them I might also look at getting new valves. The 04's have been known to drop valves. But if you are careful you can replace just the seals without removing the head..

    number 8 is the valve stem seals.. im sure he means the spark plug tube is filling with oil... you can do the tubes by only removing the rocker cover

  5. #5
    PEST!'s Avatar
    Join Date
    Jun 2008
    Location
    Rockledge Florida
    Posts
    768
    hope your right they are much easer. #27

  6. #6
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    I believe he means oil on the plug tips, as in the cyls..

  7. #7
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,136
    +1
    823
    How many hours do you have on it? Sounds like bad rings. Had the same thing happen to my 250 hour engine yesterday. Was burning oil. Plug 2 and 3 were black and oily. Compression was way down too. Probably time for a psiton or at least a ring job.

  8. #8

    Join Date
    Feb 2007
    Location
    Chino,Calif.
    Posts
    45
    Went riding today at Lake Elsinor,Southern Calif. Great day! 75 plus degrees! Anyways the ski ran awesome! I'm 250lbs and I saw 74.5mph!! Jim checked my compression and it was fine. Those mods really woke it up big time!! 231 hours and still kickin'!!!!

  9. #9

    Join Date
    Feb 2007
    Location
    Chino,Calif.
    Posts
    45
    And thanks to Jim W. for all your help!! Phil

  10. #10
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    Quote Originally Posted by rxprsn View Post
    Went riding today at Lake Elsinor,Southern Calif. Great day! 75 plus degrees! Anyways the ski ran awesome! I'm 250lbs and I saw 74.5mph!! Jim checked my compression and it was fine. Those mods really woke it up big time!! 231 hours and still kickin'!!!!
    Quote Originally Posted by rxprsn View Post
    And thanks to Jim W. for all your help!! Phil

    what about the reason this thread was open??? what happened where was the oil was it in the combustion chamber or was it in the spark plug tubes???

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 09-05-2017, 09:19 AM
  2. Help. oil on spark plugs gtx 4tec
    By Tyler1192 in forum 4-Tec Performance
    Replies: 9
    Last Post: 02-21-2013, 08:28 AM
  3. HELP 2008 RXP-X Oil on Spark plug tip
    By TundraLu in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-10-2011, 08:51 AM
  4. Oil On Spark Plugs??
    By steeevo66 in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 05-16-2010, 09:43 AM
  5. Oil on spark plugs
    By super_gtx in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-28-2008, 06:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •