Results 1 to 8 of 8
  1. #1
    Not so big kahuna
    Join Date
    Jul 2008
    Location
    Tampa, Fl
    Posts
    14

    Steering Problem RXT

    My steering has become more and more difficult over the past year to the point where I have to break it free.. Has anyone seen this issue before? is it the linkage that has corroded? Maybe the Steering Cable has corroded? The Handle Bars themselves?

    Visual inspection of the pump when I did the wear ring swap showed that it was NOT an OPAS or Reverse Gate problem (Pump moves freely with steering link disconnected).. it is the steering itself.

    So I have narrowed it down to the cable or the handlebars.. if someone could give me some guidance before I start taking the whole steering column apart I would greatly appreciate it.

    (I have searched and searched on this topic for a couple days now. A link would be appreciated if I missed a previous post)

    Thanks!!


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by spdosnd View Post
    My steering has become more and more difficult over the past year to the point where I have to break it free.. Has anyone seen this issue before? is it the linkage that has corroded? Maybe the Steering Cable has corroded? The Handle Bars themselves?

    Visual inspection of the pump when I did the wear ring swap showed that it was NOT an OPAS or Reverse Gate problem (Pump moves freely with steering link disconnected).. it is the steering itself.

    So I have narrowed it down to the cable or the handlebars.. if someone could give me some guidance before I start taking the whole steering column apart I would greatly appreciate it.

    (I have searched and searched on this topic for a couple days now. A link would be appreciated if I missed a previous post)

    Thanks!!

    Try lubbing the steering cable.

  3. #3
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,597
    +1
    4,800
    Let me guess, you ride in salt water, right?
    Yeah try lubrication first, otherwise you may need to go ahead and replace the steering cable; or better yet have your dealer replace it because it's a pain if you don't know what you're doing... and steering is not something you wanna get wrong, it's a safety issue, see this thread:
    http://greenhulk.net/forums/showthre...le+lubrication

  4. #4
    Not so big kahuna
    Join Date
    Jul 2008
    Location
    Tampa, Fl
    Posts
    14

    Worst Possible Scenario.. Okay Got It

    Thanks for the link.. Looks like exactly what I am experiencing.. Steering does work fine after 5mns of riding.. So I am assuming the cable is bad now and I should replace it. I wonder if they have updated the cable so it does not have these types of failures.

  5. #5
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,597
    +1
    4,800
    My pleasure...

    we have over 320 hours each on two RXT's and never had any problems with steering, do you ride in salt water?

  6. #6
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    i lubed my cable, worked awesome...
    read this. a bit complicated to read , but was pretty easy to do...
    http://greenhulk.net/forums/showthre...ighlight=cable

  7. #7
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    oh btw, it si definitely the steering cable is corroded or crusted with salt.
    yes the saltwater does get up into teh cable from teh bottom, and when the water dires the salt binds it up pretty bad. sometimes, ust putting the ski in the water before you try to break teh steering loose helps.
    but the lubrication method helps prevent future bind ups!!

  8. #8
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,597
    +1
    4,800
    Quote Originally Posted by lextoy View Post
    i lubed my cable, worked awesome...
    read this. a bit complicated to read , but was pretty easy to do...
    http://greenhulk.net/forums/showthre...ighlight=cable
    That's a good tip!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 RXT-X Steering problem
    By Edmonds in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-21-2015, 10:18 AM
  2. steering problem
    By sportman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 06-10-2008, 10:12 PM
  3. 05 3D Steering Problem
    By ba6636 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 05-28-2008, 12:04 PM
  4. umi steering on rxt?
    By jayohentran in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-07-2008, 04:22 AM
  5. HELP steering problem!!
    By barmy army in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 05-04-2008, 03:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •