Results 1 to 5 of 5

Thread: prop questions

  1. #1
    goinbroke09's Avatar
    Join Date
    Jan 2010
    Location
    etown MD
    Posts
    17

    prop questions

    i just pulled the prop off my xp to do some upkeep and was wondering how bad it is that i can move my impeller in and out a little with the wear ring installed.


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    your thrust bearing could be cooked, take your pump apart and if it smells like rotten eggs then it means you have water injestion, take some pics of the shaft and the bearings. Usually there is supposed to be minimum movement back and forth.

  3. #3
    goinbroke09's Avatar
    Join Date
    Jan 2010
    Location
    etown MD
    Posts
    17
    i pulled the pump cone and the fluid didnt smell burnt but i havent pulled the impeller yet to inspect bearings. but it doesnt pull so far as to come out past the wear ring its maybe 1/8" of play.

  4. #4
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Normal

  5. #5
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Forward/rear play of about 1/8" is normal. Welcome to GH!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. solas prop question
    By Top banana in forum 4-Tec Performance
    Replies: 0
    Last Post: 09-27-2006, 12:12 AM
  2. RXT prop questions
    By Mark S in forum 4-Tec Performance
    Replies: 12
    Last Post: 09-23-2006, 09:35 AM
  3. Procedure to initialize RR ECU and Prop question
    By bankyf in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-26-2006, 05:16 PM
  4. Wear ring & prop question
    By Carlos Miami RXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-21-2006, 11:55 PM
  5. Fins Damaged Ahead of Prop Question
    By Sirhc7897 in forum 4-Tec Performance
    Replies: 14
    Last Post: 02-22-2006, 11:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •