Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28

    What the hell is this?

    Hey guys my RXPX is missing badly and i cant work out what is causing it.. I have changed the plugs and replaced the coils and it still misses badly. It hunts around a little bit at idle then starts missing badly when u accelerate. It only makes it to 5500 rpms or so but it spluttering and farting constantly?? any one got a suggestion?

    i took this photo of a sensor or something that goes no where.. could this be my problem?? cheers guys
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P1090051.JPG 
Views:	159 
Size:	758.9 KB 
ID:	167095  


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Uhhh... YES! That goes to your waterbox... look for the rest of the sensor on your box!

  3. #3
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Yep! that goes in the sensor in your waterbox bro! Did you rip it out?? lol

  4. #4
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by monaroman76 View Post
    Hey guys my RXPX is missing badly and i cant work out what is causing it.. I have changed the plugs and replaced the coils and it still misses badly. It hunts around a little bit at idle then starts missing badly when u accelerate. It only makes it to 5500 rpms or so but it spluttering and farting constantly?? any one got a suggestion?

    i took this photo of a sensor or something that goes no where.. could this be my problem?? cheers guys
    THat is your exhaust sensor. It goes right on the inside of the exit pipe on water box. Looks like yours has broke loose from the fitting.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC05666.JPG 
Views:	51 
Size:	505.1 KB 
ID:	167100   Click image for larger version. 

Name:	DSC05671.JPG 
Views:	53 
Size:	586.5 KB 
ID:	167101  

  5. #5
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    dont think that would causse a miss fire but first things first. Fix that go go from there. Check coils, injectors and compression to start if youve already replaced the plugs

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Pressure test your ic. Also your exhaust sensor got hot from lack of water to the exhaust.

  7. #7
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Quote Originally Posted by GOLD06RXP View Post
    dont think that would causse a miss fire but first things first. Fix that go go from there. Check coils, injectors and compression to start if youve already replaced the plugs
    It might. Exhaust could be getting into the engine bay.

  8. #8
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by Duke View Post
    It might. Exhaust could be getting intot he engine bay.
    Very true.

  9. #9
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Good call!! could be
    Quote Originally Posted by Duke View Post
    It might. Exhaust could be getting into the engine bay.

  10. #10
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by speedskixp View Post
    your exhaust sensor got hot from lack of water to the exhaust.
    And someone can't hear a buzzer going off

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what the hell is this
    By parrothead306 in forum Tigershark
    Replies: 1
    Last Post: 09-07-2010, 02:55 PM
  2. What the hell is this?
    By VaRedneck in forum Open Discussion
    Replies: 13
    Last Post: 03-03-2009, 12:16 PM
  3. What the hell is this?
    By Rampage in forum Open Discussion
    Replies: 5
    Last Post: 02-04-2009, 09:59 PM
  4. What the hell is this called, and...
    By ADSR in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 12-22-2008, 02:34 PM
  5. Travis Church..what the hell is this?
    By peteshauling in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 03-31-2007, 10:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •