Page 1 of 7 1 2 3 ... LastLast
Results 1 to 10 of 61
  1. #1
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1

    Take a look...Tell me it aint so!

    I have been working a few hours tonight, slowly putting my stuff back together and decided to go ahead and change the oil. The oil definitly has a strong fuel smell, the oil filter is soaked with the fuel smell, and when I removed the filter I just happed to look down and see this...

    It looks like something has chewed up the bottom of the oil filter housing at the bottom, where the cover bolt attaches to. It even looks like a metal splinter between the middle section of the bottom and the side, like where metal used to be.

    Am I out of service???
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_8233.jpg 
Views:	124 
Size:	440.9 KB 
ID:	167109   Click image for larger version. 

Name:	100_8234.jpg 
Views:	77 
Size:	320.7 KB 
ID:	167110   Click image for larger version. 

Name:	100_8235.jpg 
Views:	71 
Size:	606.2 KB 
ID:	167111   Click image for larger version. 

Name:	100_8236.jpg 
Views:	81 
Size:	673.5 KB 
ID:	167112  


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    THat is pretty wild Jeremy.
    I am going to have to go look at my drive cover sitting on bench, you got me wondering what it is suppose to look like.

  3. #3
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    I'm thinking it's junk. Puts me out!

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Did you find any metal in the filter? Can you pull the front oil pump cover and see whats in it? If you cant find any large amounts of metal fragments then I would run it and check the oil pressure. Kinda looks like shity casting or something. Kinda hard to tell from the pic. Definitely strange.

  5. #5
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Quote Originally Posted by speedskixp View Post
    Did you find any metal in the filter? Can you pull the front oil pump cover and see whats in it? If you cant find any large amounts of metal fragments then I would run it and check the oil pressure. Kinda looks like shity casting or something. Kinda hard to tell from the pic. Definitely strange.
    Forgive my ignorance, but I will have to research the location of the front oil pump cover to look. I just looked in the old/current oil filter and there is nothing major, but there was tiny, tiny, tiny sparkles...like glitter. Slightly smaller than glitter.

  6. #6
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by jpeconsult View Post
    Forgive my ignorance, but I will have to research the location of the front oil pump cover to look. I just looked in the old/current oil filter and there is nothing major, but there was tiny, tiny, tiny sparkles...like glitter. Slightly smaller than glitter.
    Take a pic of the filter. I think is normal to have slight metal showing.

  8. #8
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by jpeconsult View Post
    Yes, that is your front pump.

  9. #9
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by jpeconsult View Post
    Forgive my ignorance, but I will have to research the location of the front oil pump cover to look. I just looked in the old/current oil filter and there is nothing major, but there was tiny, tiny, tiny sparkles...like glitter. Slightly smaller than glitter.
    I dont think its done. Have you ever looked in there before? I'd be willing to bet its been like that since day one but could be wrong.

  10. #10
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    I wish I could just bolt my stuff on and keep clockin' along. This sucks.

    If anyone is around their ski can you take a picture of the bottom of the oil filter housing, or forward me a picture if you know of one posted ont he forum.

Page 1 of 7 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. say it aint so! 99 gp1200 dead.
    By bigbri99 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 06-13-2010, 07:26 PM
  2. Please tell me it's not ruined....
    By LMORENO2008 in forum Polaris Open Discussion
    Replies: 17
    Last Post: 12-26-2008, 10:40 AM
  3. tell me if its bad?????
    By superduty in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 05-31-2007, 10:31 PM
  4. please have a look and tell me what you think
    By Hydrotherapy in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 12-29-2006, 09:53 AM
  5. so im new, tell me the basic mods on the rxp please
    By flyn ryan in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-19-2006, 07:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •