Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: Xp problem

  1. #1
    derwin66's Avatar
    Join Date
    Oct 2007
    Location
    Brisvegas, Australia
    Posts
    64

    Xp problem

    Hi people, I am after a little advice. I just finished two weeks leave and was at the beach for the entire time wave jumping. On the last day, last hour I was out with my wife when the accelerator cable felt like it stuck half way and I could only accelerate to half speed. I limped back to the ramp and went out for the rest of the day on the back seat of my wife's RXP so it was all good. However when I got home to clean the 97XP I checked the linkages and they all seemed good, the thumb throttle would only go half way. What should I look for to establish why, or is it a good chance the cable has gone and needs to be replaced>


  2. #2
    Joe Stang's Avatar
    Join Date
    Aug 2008
    Location
    Durham, CT
    Posts
    1,928
    +1
    61
    was only getting half the rpms... did it sound like it was on 1 cylinder??

  3. #3
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    get a new cable and try that first...there are a lot of salvage yards that will get you one cheap

  4. #4
    dghal's Avatar
    Join Date
    Jul 2008
    Location
    League City Texas
    Posts
    280
    give a quick visual to the linkage at the carbs,, manually open and close to make sure something is not amiss in the carbs ( engine OFF )

  5. #5
    derwin66's Avatar
    Join Date
    Oct 2007
    Location
    Brisvegas, Australia
    Posts
    64
    I can manually open using the linkages, the thumb throttle will only move half way and wont go to the grips

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Take the cable ends loose from the carb wheel and finger throttle. Then try to slide it back and forth. If it still binds then it's time for a new cable. It must have gotten damaged or pinched, as they seldom fail.

  7. #7
    derwin66's Avatar
    Join Date
    Oct 2007
    Location
    Brisvegas, Australia
    Posts
    64
    Thanks for the advice I finally got home and got a chance to have a look at it. I checked the oil injection cable and it looks like the tab that holds the cable has broken/rusted away and the cable was loose jammed against the bow hose not allowing it to move. Any ideas on how to fix this tab or problem, can I buy the tab or just fabricate something new?

  8. #8
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    If you are talking about the front of the oil pump you will probably have to buy a new pump. The cams are not sold separately.

  9. #9
    derwin66's Avatar
    Join Date
    Oct 2007
    Location
    Brisvegas, Australia
    Posts
    64
    Yeah I have done a bit of research about that, looks like I will have to buy one. Thee are a few on evil bay I might have to bid for unless someone out there on the forum has one they want to sell.

  10. #10
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    I may have an 800 oil pump, let me look tomorrow for it.
    SHOOTER

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XP problem...stator or recifier?
    By babyjoker494 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 08-05-2008, 04:21 PM
  2. 96 XP Problem...any ideas?
    By babyjoker494 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 08-04-2008, 05:33 PM
  3. 93 seadoo xp problems
    By b93xp in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-17-2008, 11:07 PM
  4. 96 XP Problem
    By XPTEX in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-19-2008, 01:14 PM
  5. 97 xp problems
    By shawnIII in forum 2-Stroke Performance
    Replies: 5
    Last Post: 03-07-2008, 11:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •