Results 1 to 4 of 4
  1. #1
    Makesumwake's Avatar
    Join Date
    Jan 2010
    Location
    Miami, FL
    Posts
    53
    +1
    3

    VTS - white smoke! Any help would be great

    I have a 2004 RXP. The VTS didnt work when i bought it due to water getting inside the housing. i Bought a used housingmotor assembly on ebay that was supposed to work (it was originally off a GSX), and it looked great, like new. the motor tested good also.
    i initially had to get the BUDS reprogramming also to get the RXP to recognize the VTS unit, typical problem here on the the board.

    after that, all the new unit would do was make clicking sounds (relays).
    then white smoke started pouring out of the VTS housing a few tries later.

    Now this isnt supposed to happen to my knowledge due to fuse protection.
    but none of my fuses are blown!

    so now my question is - is there something wrong with the electronics on the RXP or just the VTS unit i had? possible incompatibility?

    i dont want to fry another new VTS unit!!!

    thanks

    -Phil


  2. #2

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    the module is common to go out-- clicking relays or nothing at all or blowing the 7.5 amp fuse or any combination of-- GSX is from 96-00-- 9-13 yrs. old. I have 12+ bad modules on the shelf myself...

  3. #3
    Makesumwake's Avatar
    Join Date
    Jan 2010
    Location
    Miami, FL
    Posts
    53
    +1
    3
    just to clarify, by module, you are talking about the VTS housing, not some other module on the RXP right?

  4. #4

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    Quote Originally Posted by Makesumwake View Post
    just to clarify, by module, you are talking about the VTS housing, not some other module on the RXP right?
    Yes, the VTS housing / module -- 1 and the same. The motors are very reliable if they have not taken on water.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 05-08-2013, 11:07 PM
  2. GTX RFI new motor issues, Any help would be great
    By thetolleyman in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-11-2012, 04:56 PM
  3. Unsure how these Mikuni Fuel pumps are plumbed...... Any Help would be appreciated...
    By SJ-(KY) in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-19-2010, 03:54 PM
  4. 96 gsx thru hull question?? Any help would be greatly appreciated
    By Stirtonhotrodz in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-29-2010, 07:38 AM
  5. A little help would be great
    By jonjonwells in forum Polaris Open Discussion
    Replies: 19
    Last Post: 06-29-2007, 10:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •