Results 1 to 4 of 4
  1. #1
    jetskibrian's Avatar
    Join Date
    Nov 2009
    Location
    Poquoson Virginia
    Posts
    1,052
    +1
    188

    I did not follow any body today.

    Maybe I should have, cause I sure didn't catch any fish.
    I departed Rudee Inlet in Virginia Beach at 0645 and was off of Currituck LIght N.C. by 0735. I was an awesome run at 45-50mph, a couple hundred yards off of the beach on the edge of the breakers. The 60 degree west wind made it even nicer. Unfortunately even though I ran all the way to Duck North Carolina, I never saw water temps above 40.5. I never saw any bait or decent fish marks either. I ran inshore on the way down and 3 miles offshore on the way back. I covered about 88 miles round trip and burned 20.5 gallons. I think I will wait a couple weeks and see if the temps come up inshore before I make any more long runs. It was still a fun day and I would rather be riding the jet ski in the middle of the winter than riding a desk any day. Ha! Here are some picture from my trip today.









































  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    You caught some good pics.. Thanks for posting.

  3. #3
    freakboy35's Avatar
    Join Date
    May 2008
    Location
    (ft lauderdale)
    Posts
    1,526
    +1
    8
    WOW, those are great pictures!

  4. #4
    Just snoozin' on the couch M447's Avatar
    Join Date
    Sep 2008
    Location
    Canada
    Posts
    699
    +1
    22
    I am soooo envious. What a beautiful place! Thanks for sharing those!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. my ultra did not start today
    By blu 250x in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 09-06-2007, 05:32 PM
  2. Any body been to Egret lately??
    By BULLRAIDER in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 05-20-2006, 12:07 PM
  3. did the water box mod today
    By flyn ryan in forum 4-Tec Performance
    Replies: 0
    Last Post: 03-26-2006, 10:12 PM
  4. Any body got Call OF Duty 2 for PC?
    By kenshin89 in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 03-08-2006, 01:52 AM
  5. New RR IC still not helping, any ideas ????
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 30
    Last Post: 08-24-2005, 09:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •