Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471

    fuel guage reads half tank when full

    changed out the fuel pump to a walbro reinstalled it and the gas guage reads half when its full ...saw something on this a few years ago..but couldnt find it..

    know i did something wrong almost empty should fix it now...

    i know it is somthing i just over looked


  2. #2
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Quote Originally Posted by breon View Post
    changed out the fuel pump to a walbro reinstalled it and the gas guage reads half when its full ...saw something on this a few years ago..but couldnt find it..

    know i did something wrong almost empty should fix it now...

    i know it is somthing i just over looked
    You bent the float arm when you replaced the pump...remove the fuel pump assemply and fix the arm to a 90 degree angle. Common issue! --J

  3. #3
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    it was a bear to get out of there.. i cansee how that might have happened ...at least it worked when it is important ..just before it was empty ..ill get it out again and give it a look thanks

  4. #4
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Quote Originally Posted by breon View Post
    it was a bear to get out of there.. i cansee how that might have happened ...at least it worked when it is important ..just before it was empty ..ill get it out again and give it a look thanks
    Someone correct me if wrong, I haven't worked on jet ski gas floats, but tons of car fuel gauges. Most all work off resistance to ground, so a 12 volt source is applied to your gauge and then the float rides up/down a potentiometer with windings that increase or decrease the resistance to ground(sensor wire going to sending unit from gauge) depending on position of the float.

    When you get float out check with ohm meter or move float manually. Possible resistance to ground is different than other unit?Or as suggested bent float rod?

  5. #5
    you clocked it wrong when you put it back together so now it tops out in the lower part of the tank... ask me how i know

  6. #6
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    bringing this back up

    i never fixed it because it read correctly on the second half of the tank...when it was needed ...

    well once it decided not to and i ran out and had to get rescued... embarassing but it happened..luckily i wasnt out in the middle of nowhere..

    so i took it apart today unfortunately i dont see anything wrong..the arm is at 90 deg...so i didnt bend it... when it is installed it points to the front at about 1;30 2 o'clock basically points at the battery ...when everything goes in ..i think there is a molded recession for the set up to sit in at the bottom of the tank ..the top bolts will only line up one way so it cant be rotated...so i think ..

  7. #7
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    I swear the ol' bent arm is 99% the cause of this problem. I don't remember much about the rest of the set-up, but do remember the little electric strip where the arm makes the reading...thats about it. sorry can't be any more help. --J

  8. #8
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    the 08 the fuel pump housing you remove from the tank has an arrow that your supposed to line up with a line on the tank itself when reinstalling. Don't know if your year has the same just adding info

  9. #9
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    ya the bolts are spaced odd .you can only get the bolts to line up one way ...

  10. #10
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    Its either the ARM is bent or the arm is fouling on something in the tank.

    Get it out, check for bends that aren't supposed to be there and re-install the unit so the arm is towards the rear of the hull (from memory) and the connector is to the port side.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 GP1200: Low fuel warning but the tank is full.
    By dannyual777 in forum Yamaha Old School Skis
    Replies: 26
    Last Post: 07-05-2015, 10:45 AM
  2. MSX 140 fuel gauge reading half when empty?
    By dubl-z in forum Polaris Open Discussion
    Replies: 17
    Last Post: 08-26-2011, 01:10 AM
  3. Fuel gauge reading full, but the tank is half empty??
    By aussie rxp in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-02-2009, 07:40 AM
  4. low fuel guage with tank full?
    By 06stijoe in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-30-2009, 09:23 AM
  5. Fuel gauge reads FULL when not...
    By BD in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-31-2006, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •