Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: plz help me!!!

  1. #1
    tysonfzr's Avatar
    Join Date
    Nov 2009
    Location
    johor bahru malaysia
    Posts
    621

    plz help me!!!

    2day i juz installed riva power cooler,riva b1,riva heavy duty shaft,riva BOV,engine breather kit n rNd powershot.after installing i start the engine to test,to my surprise the rpm only 4500.then i took off the powershot n the rpm goes to 5000,the throttle response is damn slow lack of power.we check everything no leakage,i didnt adjust anything on the powershot coz as i knw its pre progamme..how come like tis?wat could b the problem?plz advice tks....


  2. #2

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,846
    +1
    527
    sounds like you supercharger is not making any boost. maby your sc wheel came loose on shaft ?Check to be sure all your hoses are hooked up and have not blowen off at there hook up points.

  3. #3
    RUSH.'s Avatar
    Join Date
    Aug 2007
    Location
    Orlando
    Posts
    868
    +1
    17
    Quote Originally Posted by 2fast4u View Post
    sounds like you supercharger is not making any boost. Check to be sure all your hoses are hooked up and have not blowen off at there hook up points.

    +1000000000000

  4. #4
    tysonfzr's Avatar
    Join Date
    Nov 2009
    Location
    johor bahru malaysia
    Posts
    621
    Quote Originally Posted by 2fast4u View Post
    sounds like you supercharger is not making any boost. maby your sc wheel came loose on shaft ?Check to be sure all your hoses are hooked up and have not blowen off at there hook up points.
    wat u mean by 'blowen off at there hook up points?'

  5. #5
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Sounds like a hose is off.

  6. #6
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    did you toruqe the s/c wheel correct,ive read of shafts going on wheel changes...hope not tho..
    take power filter pipe off for a quick visual and wriggle with fingers(engine off)

  7. #7
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Hey Tyson,

    Are you revving it on the trailer or in the water? Sorry, just want to be clear. Don't freak out just yet. It will probably take a little tweaking to get this setup working right.

    If your results are from "on the water testing" check all your hoses. Make sure the BOV is operating correctly and not stuck open or anything. Check for anything that could cause you to loose boost.

    Do you have a boost gauge?

    Also listen for any difference in the sound coming from the supercharger. If that new wheel wasn't torqued correctly and get's loose, it could really do some expensive damage.

  8. #8
    tysonfzr's Avatar
    Join Date
    Nov 2009
    Location
    johor bahru malaysia
    Posts
    621
    Quote Originally Posted by hitman View Post
    Hey Tyson,

    Are you revving it on the trailer or in the water? Sorry, just want to be clear. Don't freak out just yet. It will probably take a little tweaking to get this setup working right.

    If your results are from "on the water testing" check all your hoses. Make sure the BOV is operating correctly and not stuck open or anything. Check for anything that could cause you to loose boost.

    Do you have a boost gauge?

    Also listen for any difference in the sound coming from the supercharger. If that new wheel wasn't torqued correctly and get's loose, it could really do some expensive damage.
    i rev it on the trailer,we check all the hoses no leakage.i dun have a boost gauge the BOV is in correct position too.the wheel was torqued correctly but the supercharger sound quite noisy i mean quite loud n weird..i will check out the supercharger n test again later..

  9. #9
    Addicted Member 5001craig's Avatar
    Join Date
    Jul 2007
    Location
    Northeast Indiana
    Posts
    2,924
    +1
    11
    See if it does the same thing in the water.

  10. #10
    tysonfzr's Avatar
    Join Date
    Nov 2009
    Location
    johor bahru malaysia
    Posts
    621
    Quote Originally Posted by 5001craig View Post
    See if it does the same thing in the water.
    huh?u mean on water n on trailer is difference?but the throttle response is so slow its like when u trottle for a second then the power come...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help me!!! New To Jet skis! Need Advice plz!
    By sea one in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 04-13-2015, 08:43 PM
  2. 97 sltx 1200 no spark...plz help me get her going
    By Danee in forum Polaris Open Discussion
    Replies: 24
    Last Post: 08-30-2010, 09:50 PM
  3. Help me with my first mod plz
    By fzr_rider in forum Yamaha PWC Performance (4-stroke)
    Replies: 18
    Last Post: 06-15-2010, 09:35 PM
  4. RXT OR RXP plz help me decide
    By RIVAFTW in forum 2-Stroke Performance
    Replies: 4
    Last Post: 08-08-2007, 12:44 PM
  5. 05 rxp or 00-03 xp? help me decide.
    By djburkeen in forum Sea Doo Open Discussion
    Replies: 23
    Last Post: 06-06-2005, 12:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •