Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 54
  1. #1
    SHO-08's Avatar
    Join Date
    Jan 2010
    Location
    SFlorida
    Posts
    115

    Can you guys help a girl out? :)

    Hi!

    I have an 08 SHO with around 25 hrs on it... anyhoo I ran it all day on the ICW here in florida and for about 10 minutes offshore (too rough!) on my way back to the marina I ended up racing a buddy of mine, throttle was wide open and then it sounded / felt like the engine missed?! didn't backfire or anything... It was flushed and the engine sounded a bit rough what did I do to it?
    Last edited by SHO-08; 01-27-2010 at 10:10 PM.


  2. #2

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2
    First off start with the simple things. Check the oil level, Do a compression test, make sure you didn't suck up something and over heat the motor. Post up your results and we can go from there.

    Oh yea welcome to the forum there is a TON of information here

  3. #3
    SHO-08's Avatar
    Join Date
    Jan 2010
    Location
    SFlorida
    Posts
    115
    Quote Originally Posted by Lvnspeed View Post
    First off start with the simple things. Check the oil level, Do a compression test,
    Thanks for the welcome! I have been reading old threads all night!
    I have no way of doing a compression test, but I will go and check the oil etc in the morning. Guess its Riva here I come.... again.

  4. #4

    Join Date
    Feb 2006
    Location
    Birmingham AL
    Posts
    2,924
    +1
    2
    Compression guages are cheep.....

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Welcome

  6. #6
    SHO-08's Avatar
    Join Date
    Jan 2010
    Location
    SFlorida
    Posts
    115
    Quote Originally Posted by K447 View Post
    Welcome
    Thank you!
    Well I am ready to go sort her out, however the marina forklift was busy this morning and I didnt want to wait. So I will go up 2morrow AM after the school run. Gives me at least 5 hours to try and find the problem! Plus the service center will be open and if I need a hand one of the guys is always happy to help! Being a chick does help sometimes!:yay2:

  7. #7
    It's not the destination, it's the journey!! Rip'nTear SHO's Avatar
    Join Date
    Apr 2008
    Location
    Ft. Lauderdale
    Posts
    4,573
    Welcome to the forum! Let us know what you find out...

  8. #8
    It's not the destination, it's the journey!! Rip'nTear SHO's Avatar
    Join Date
    Apr 2008
    Location
    Ft. Lauderdale
    Posts
    4,573
    Quote Originally Posted by SHO-08 View Post
    Thank you!
    Well I am ready to go sort her out, however the marina forklift was busy this morning and I didnt want to wait. So I will go up 2morrow AM after the school run. Gives me at least 5 hours to try and find the problem! Plus the service center will be open and if I need a hand one of the guys is always happy to help! Being a chick does help sometimes!:yay2:


    Yes.....you know our weaknesses...

  9. #9
    Just snoozin' on the couch M447's Avatar
    Join Date
    Sep 2008
    Location
    Canada
    Posts
    699
    +1
    22
    Welcome to the Hulk. Nice to meet a riding sister. Happy riding!

  10. #10
    smbstyle's Avatar
    Join Date
    Jul 2009
    Location
    Georgia
    Posts
    545
    Welcome! Post up pics, and of the ski too! lol

    anyways, first thing I would check is the clips going to the spark plugs. Mine popped off one time on a ride and the same exact thing happened, it was running rough, wouldnt go over 6000rpms, and sounded like it was missing when i put it on the trailer. sure enough the clip popped off going to the top of the plug.

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ok, got a multimeter, would you guys help me check some NO spark issues now??
    By Old Atari Nut in forum Polaris Open Discussion
    Replies: 6
    Last Post: 10-16-2008, 02:24 AM
  2. Can you guys tell me what this is ?
    By boocat in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 08-21-2008, 10:38 PM
  3. Can you guys help me brainstorm with my summer "business"
    By HallPass in forum Open Discussion
    Replies: 28
    Last Post: 05-15-2008, 10:07 PM
  4. can u guys help me with a mod
    By marshro in forum 2-Stroke Performance
    Replies: 2
    Last Post: 05-05-2008, 11:04 AM
  5. Can you all help me with a school project?!
    By HallPass in forum Open Discussion
    Replies: 40
    Last Post: 03-11-2008, 04:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •