Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1

    94 750 SL Rebuild--Low Compression Mag 95PSI

    Ok all time ot get ready for my March 1st ride

    Check the compression at the end of the season last year and found ski was running well, but not great..

    140P/140C/95M

    So its rebuild time

    Pulled it apart today and found>>>>>
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Reid Mag.jpg 
Views:	67 
Size:	4.16 MB 
ID:	169336   Click image for larger version. 

Name:	Reid Center.jpg 
Views:	58 
Size:	4.15 MB 
ID:	169337   Click image for larger version. 

Name:	Reid PTO.jpg 
Views:	63 
Size:	4.70 MB 
ID:	169338  


  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    Im thinking Lean, Rich. Good

  3. #3
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    So pulled the Mag apart to get an idea of where i am

    and found this.....

    Lot of blow by, maybe the rings didn't seat properly????

    Head damage was already there form a previous rebuild when I chipped a rings (forgot to clean up the exhaust port after the previous bore)
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1-24-10 190.jpg 
Views:	57 
Size:	3.07 MB 
ID:	169345   Click image for larger version. 

Name:	1-24-10 189.jpg 
Views:	51 
Size:	3.77 MB 
ID:	169346  

  4. #4
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    more

    Now I am thinking a lean or water blockage seize at one point. I did have an over heat issue last summer. But got it fixed (pisser adapter we too small 1/4" instead of 3/8")
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1-24-10 189.jpg 
Views:	59 
Size:	3.77 MB 
ID:	169354   Click image for larger version. 

Name:	1-24-10 197.jpg 
Views:	60 
Size:	3.65 MB 
ID:	169355   Click image for larger version. 

Name:	1-24-10 201.jpg 
Views:	59 
Size:	4.17 MB 
ID:	169356  

  5. #5
    Hayabusa's Avatar
    Join Date
    Sep 2006
    Location
    Trenton Michigan
    Posts
    493
    Quote Originally Posted by seaobin View Post
    Im thinking Lean, Rich. Good
    +1 That's how I see it.

  6. #6
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    If i clean this piston up, can I reuse, or should i just get a new one??

    Bore to .75

    hone over and get .75 rings (.5 over piston)

    hone and try .5 rings again

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    IMO, that piston is bad. Go with a new one. Hell of alot of scuffing going on inside that cyl.

    Have that cyl checked for out of round and taper. Esp if the rings weren't sealing well.

    In your last pic, are you using 2 base gaskets?

  8. #8
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    1 base gasket with copper seal


    I think i will have it bored to .75 and get a new piston

    should i move it to the center.. does it matter? not racing.

  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Quote Originally Posted by seaobin View Post
    1 base gasket with copper seal


    I think i will have it bored to .75 and get a new piston

    should i move it to the center.. does it matter? not racing.
    What size are the other 2?

    .75mm would be puishing it IMO.

    But if the other 2 are .5mm, you'll be fine.

  10. #10
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    yes, all three are at .5 right now

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 750 SL would not shut off!!! HELP!!!
    By ashelgren in forum Polaris Open Discussion
    Replies: 11
    Last Post: 09-01-2008, 09:05 PM
  2. 94 750 sl for sale
    By bryanowens in forum Polaris Classifieds
    Replies: 0
    Last Post: 06-19-2008, 10:47 AM
  3. 94 750 sl electrical problem
    By bryanowens in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-05-2008, 12:08 AM
  4. 94 750 sl question
    By minersny in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-13-2007, 06:24 PM
  5. 94 750 SL fuel pump?
    By rfjr23 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-03-2007, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •