Results 1 to 4 of 4
  1. #1

    Stator CDI problems

    I have a 1999 GLX 1050 triple CDI box number 4060180 Coil Pac 4010174 I'm not sure are these the updated Ign? My Stator readings are Blk to Gnd = 4.5 ohms, Blk to Pur = 0 ohms, Blk to Gry = 107.2 ohms I have no spark battery fully charged Kill switch and Laynard test ok. What the ???? Thanks John


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by jgiljum View Post
    I have a 1999 GLX 1050 triple CDI box number 4060180 Coil Pac 4010174

    I'm not sure are these the updated Ign?

    My Stator readings are Blk to Gnd = 4.5 ohms, Blk to Pur = 0 ohms, Blk to Gry = 107.2 ohms

    I have no spark battery fully charged Kill switch and Laynard test ok. What the ???? Thanks John
    That would be an SLX 1050

    First check is always the battery, while under load.
    Put your voltmeter on the battery, and crank the engine.
    While the engine is cranking
    , what is the voltage?
    If the voltage is not above 10.6 volts, you won't have spark. Replace the battery.

    Your stator ohm measurements don't entirely make sense
    I think you have the original, non-updated ignition.

    Black stator wire to ground (engine block) should measure zero ohms. Is there a small black wire running between the electrical box and the battery negative?

    Stator coil ohm tests for non-updated 900 & 1050 engines
    Black to engine ground: less than 1.0 ohms, should be very close to 0.0 ohms

    Black to Purple: 1200 ohms
    Black to Gray: 88 or 140 ohms

    Yellow to Red/Purple: 0.75 ohms
    Yellow or Red/Purple to engine block: no connection/infinite

    More good info;
    Polaris Domestic (red) engine

  3. #3

    Stator CDI problems

    Batt voltage while cranking 12v have the charger hooked up, there is a black second wire ti the batt neg side when hooking that wire up something in the e box starts making noise? I ended up hooking a 9v batt to the stator and ground and still no spark or very very weak at best. I think the stator must be bad. Any way of checking the cdi box? Thanks John

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by jgiljum View Post
    Batt voltage while cranking 12v have the charger hooked up,

    there is a black second wire to the batt neg side when hooking that wire up something in the e box starts making noise?

    I ended up hooking a 9v batt to the stator and ground and still no spark or very very weak at best.

    I think the stator must be bad. Any way of checking the cdi box? Thanks John
    Is there a healthy PWC battery installed, or are you 'boosting' a weak battery with an external battery charger/booster?

    A healthy battery will not provide 12 volts while cranking. The voltage would normally be something less than 12.0 volts, while cranking the engine.

    We have had several reports over the years of external battery chargers/booster causing the CDI to fail, especially if the starter was engaged with the external feed still connected.

    If you don't have a decent battery in there, don't use an external battery booster. Get a new battery.

    Do not use automotive battery chargers or boosters that are not adjustable for the small(er) size PWC battery.

    What kind of noise comes from the electrical box when you re-connect the second ground wire? A clattering or buzzing sound?

    With an original, non-upgraded ignition system on a domestic engine, that smaller black ground wire to the battery is important for the correct operation of the system.

    If either the stator or CDI is bad, your best option is to replace both with the update kit. The update kit provides a new stator and a new CDI, at a reasonable price.

    And the updated parts will be more reliable than the original design.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. timing problem with new stator/CDI/coil update kit
    By Pritchard in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-25-2012, 06:19 PM
  2. cdi problem?
    By dustin in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-16-2009, 09:40 PM
  3. polaris freedom 2004 stator, cdi,coils,wires
    By soejberg in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 08-06-2009, 11:15 AM
  4. stator,cdi upgrade(1999 1050)
    By rmaser in forum Polaris Open Discussion
    Replies: 4
    Last Post: 01-29-2009, 09:56 AM
  5. stator or cdi problem!!
    By ugadawg131 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 12-07-2006, 12:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •