Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    GPR no mid range

    I have a 01 gp1200r it has a new sbt moter and a D plate. I cant get the thing to holeshot for crap replaced carbs and its worse. seems like idle is ok and top end is great about 64 mph. Any help would be great.


  2. #2
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Power valves might be stuck in the open position.

  3. #3
    slydogge's Avatar
    Join Date
    Jul 2009
    Location
    Florida
    Posts
    306
    man you beat me to it. I second the power valves. I had a friends boat do the same thing! Powervalves were stuck open. Best way to fix it... RIVA VALVES

  4. #4

    cool

    Thank you for the advice i never thought about that. I guess put it in the water w/o seat and rev on trailer?

  5. #5

    You were right

    Tested PV moter it will not run one way it will return to open but will not close.
    Now i have to find a new one at a good price.


    Thanx alot guys

  6. #6
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Pull the cables off at the pulley for the PV's, and make sure they turn freely. Then try your motor with the cables disconnected and see if the cables move. Might not be a cable issue, could be a Valve issue.

  7. #7

    al good

    I tested the servo per the manual with a battery and a jumper, sure enough the moter is bad. I am a Electronic Tech ill try to fix the moter circuit.

  8. #8
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    I have a good 2000 motor and cables. If you need it and it fits (3 pin adapter) make an offer.

  9. #9
    slydogge's Avatar
    Join Date
    Jul 2009
    Location
    Florida
    Posts
    306
    oh yea my motor is off of a 2003 dont know if they are different?

  10. #10
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,800
    +1
    449
    Quote Originally Posted by slydogge View Post
    oh yea my motor is off of a 2003 dont know if they are different?
    yes, 03 and later is different than 00-02

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 GTX Limited-No mid range
    By dpfly in forum Sea Doo How To & FAQs
    Replies: 10
    Last Post: 05-07-2013, 09:32 PM
  2. no mid range power help!
    By Corey_ in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-28-2012, 04:48 PM
  3. 95 780 slx no mid range Idle and full throttle is all
    By fireman24mn in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-31-2009, 03:43 PM
  4. 99 gsx limited mid range bogg
    By PRIME in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-23-2007, 03:10 AM
  5. please help ! 06 GPR no power , yamaha cannot resolve
    By stewartgpr in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 06-11-2007, 01:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •