Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Help 04 RXP is slow!

    Starts fine flashes MAINT then i gun it only goes to about 45 MPH and tops out.. whats the problem? anyone?

    thanks!


  2. #2
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    what are your top speed RPMs? ... sounds like your supercharger potentially failed and needs a rebuild. do not run the machine anymore until u know for sure

  3. #3
    Quote Originally Posted by Shibby1485
    what are your top speed RPMs? ... sounds like your supercharger potentially failed and needs a rebuild. do not run the machine anymore until u know for sure
    around 6000 i believe

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    you know where the supercharger is? ... there's a black ruber hose that goes into the supercharger INTAKE... take that off, stick ur finger in it and try to turn the impeller inside with ur finger with minimal effort. if she spins, it's blown up...

    but given what u've said so far, consider it a 99% chance u supercharger clutch kit is cooked.

  5. #5
    Quote Originally Posted by Shibby1485
    you know where the supercharger is? ... there's a black ruber hose that goes into the supercharger INTAKE... take that off, stick ur finger in it and try to turn the impeller inside with ur finger with minimal effort. if she spins, it's blown up...

    but given what u've said so far, consider it a 99% chance u supercharger clutch kit is cooked.
    anyway you can show me it in a pic so i don't mess anything up? is there a way that i can hit like set 5 times or hold it down and it will give me an error code?

  6. #6
    anything else i should check?

  7. #7
    V-Tec, 4-Tech that's how I roll meirvin's Avatar
    Join Date
    Feb 2006
    Location
    Dallas/Ft Worth, Tx
    Posts
    1,514
    +1
    3
    are you using the yellow key and not the white one correct?

  8. #8
    Quote Originally Posted by meirvin
    are you using the yellow key and not the white one correct?
    correct.. I even tried to learning key to see what i topped out at about 30mph.

    Going to do what Shibby1485 said and check the supercharger right now.

  9. #9
    Quote Originally Posted by Shibby1485
    you know where the supercharger is? ... there's a black ruber hose that goes into the supercharger INTAKE... take that off, stick ur finger in it and try to turn the impeller inside with ur finger with minimal effort. if she spins, it's blown up...

    but given what u've said so far, consider it a 99% chance u supercharger clutch kit is cooked.
    stick my finger in the hose or the hole the hose goes into?

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    there's a black rubber hose that's sort of ribbed and goes around the motor and into the supercharger intlet. remove that hose, push it back out of the way, and stick ur finger into the actual supercharger housing into the inlet... u'll feel the impeller blades in there... try and turn it clockwise with ur finger.

    it should NORMALLY either be EXTREMELY resistant and/or not turn at all. if it's freewheeling and easily turning you need a new clutch kit.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I need alot of help. 04 RXP
    By HP Solutions in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-30-2010, 04:06 AM
  2. Help 04 Rxp wont start
    By region8racer in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-17-2009, 11:40 PM
  3. Help 04 Rxp wont start
    By region8racer in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-13-2009, 04:52 PM
  4. Help, '04 RXP seized
    By ubernoob in forum 4-Tec Performance
    Replies: 50
    Last Post: 07-04-2009, 11:17 PM
  5. my 04 rxp is screwed for the bug
    By buddydoo in forum 4-Tec Performance
    Replies: 39
    Last Post: 06-05-2007, 10:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •