Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Jun 2005
    Location
    Schaumburg, IL
    Posts
    20

    RXP hull leaking

    I have an 04 RXP that's leaking from the drive shaft, does anyone have an idea what would cause this? I had ingested some rocks and had to replace the impeller, but saw no other damage. I took the ski out and it ran good 8150 rpm's I ran for about 25 miles, then coming out of a no wake it was cavating badly. I could not go anywhere other than idle, took it to shore an it was filling up with water quick. I put it on the trailer and it was leaking from the drive shaft. Any help would be greatly apperacited before I tear this thing apart.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    It sounds like your carbon seal gave out on you.

  3. #3

    Join Date
    Jun 2005
    Location
    Schaumburg, IL
    Posts
    20
    From looking at the micro fish that was one of the things I was leaning to, I guess this means I have to pull the drive shaft? Will I need any special tools to do this?

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    There is a driveshaft tool that slides the slide ring back so you can remove the circlip, but i always just use my hands. It takes a lot of force, but can be done without the tool.

  5. #5

    Join Date
    Jun 2005
    Location
    Schaumburg, IL
    Posts
    20
    Thanks for your help Jerry.

    I'll let you know how it goes..

  6. #6
    i had a leak with my 04 rxp & it turned out to be caused by the motor mounts being broken,drive shaft pulled away from the impeller.try to lift up on the motor,if it moves you have the same problem i replaced the front mnt with the rr solid.

  7. #7
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    +1
    1
    Zoom Zoom, i had the same problem as Breister before but i would have to agree on the carbon seal being the culprit. If you need the floating ring tool i have one and will gladly lend it too you. I had a hard time with my driveshaft since i'm not beefy like "the hulk".

  8. #8
    i hate to come off as a know it all ,but i have had my rxp & my 2001rxx sink from a bad carbon ring/boot problem,in both skies that had a bad carbon ring i was still able to get the skies up on plane and get very close to top speed. zoom is saying his ski will only idle around & thats what happened to me this last time,if the drive shaft pulls away from the front of the impeler it just spins & will not do more than idle speeds.lol zoom!

  9. #9
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    +1
    1
    Breister, i also noticed that he said he was cavitating which wouldn't be happening due to the stripped driveshaft and impeller splines if he's got a broken motor mount. I will however say that my experience with a broken front motor mount did involve taking on water but no cavitation. As you can see from my past trouble's i know all too well about that.

    http://www.greenhulk.net/forums/showthread.php?t=2430

    Still it wouldn't be a bad idea to remove the driveshaft to check the splines on both ends as well as the carbon seal since it could have also been damaged.

  10. #10

    Join Date
    Jun 2005
    Location
    Schaumburg, IL
    Posts
    20
    Thanks for the added input, I will check the motor mount when I get home tonight. As for the cavating if you started real slow the pump seemed hooked after a second or two it would just spin and go no where. Wouldn't I hear or feel the drive shaft moving in and out of the impeller? How would a bad seal make it cavate?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 107
    Last Post: 11-01-2011, 08:47 PM
  2. RXP Hull Same as 3 Seaters?
    By Haislip in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-08-2006, 07:21 PM
  3. Hull Leak
    By big83bronco in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-24-2006, 10:18 PM
  4. Should I put a Keel Guard on my RXP? Hull protector.
    By BlackHawk in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 03-25-2006, 12:59 PM
  5. deep scratches in rxps hull on bottom WHAT to do?
    By macattack in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-23-2005, 09:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •