Results 1 to 8 of 8
  1. #1
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    chesapeake Va.
    Posts
    270

    another question for the 785 crew!!!!

    ok i figure by the time im done with this ill know all of you on a first name basis. ok it appears like i have everything wired properly is there a way for me to check it out via the MFD without actually running the engine i dont have any of the engine components hooked up.
    Thanks again guys

    (LUGS i prob should have just drove up there and bought the whole ski from you)


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Quote Originally Posted by killcraft View Post
    ok i figure by the time im done with this ill know all of you on a first name basis. ok it appears like i have everything wired properly is there a way for me to check it out via the MFD without actually running the engine i dont have any of the engine components hooked up.
    Thanks again guys

    (LUGS i prob should have just drove up there and bought the whole ski from you)
    just hook up the battery and see what happens
    as long as you have the ground on the motor and the r/p wire hooked up in the elect box

  3. #3
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    chesapeake Va.
    Posts
    270
    ok ill give it a whirl

  4. #4
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    chesapeake Va.
    Posts
    270
    ok flashing red light says fuel (there is no fuel so its got that right) is the red light from the low fuel or is that something else also it shows trim at full down position and wont move when the button is pressed.

  5. #5

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Quote Originally Posted by killcraft View Post
    ok flashing red light says fuel (there is no fuel so its got that right) is the red light from the low fuel or is that something else also it shows trim at full down position and wont move when the button is pressed.

    red light is from fuel
    and hold the bilge button at the same time as the trim and it should go up and down

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Pressing the Set button for a second should turn off the red warning lamp for five minutes.

    Holding the bilge button down should run the bilge pump, AND provide power to the Trim motor.

    Multi-Function Display (MFD)

  7. #7
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    chesapeake Va.
    Posts
    270
    awesome looks like everything works nothing smells like its burning. got one last question how do i check that the exhaust valve motor is working properly? do i have to time them or anything?

  8. #8

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Quote Originally Posted by killcraft View Post
    awesome looks like everything works nothing smells like its burning. got one last question how do i check that the exhaust valve motor is working properly? do i have to time them or anything?
    you cannot check it till it runs .
    you can adjust the cables so theres just a touch of play in them ,after the cables are adjusted lift the valve up with your finger tip and it should snap closed you should here it hit bottom

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. quick question for the pro's(785)
    By jkevin50 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-05-2010, 03:43 PM
  2. Question for the prop bending guru's
    By Green Hulk in forum Yamaha PWC Performance (2-stroke)
    Replies: 112
    Last Post: 12-03-2009, 02:58 AM
  3. Cold air intake questions for the brain trust........
    By SKR8PN in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-24-2005, 05:21 PM
  4. Question for the resident computer gurus.
    By BertInTexas in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-14-2005, 04:24 AM
  5. Question for the Hulk
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-20-2005, 07:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •