Results 1 to 8 of 8
  1. #1

    Join Date
    Jul 2007
    Location
    South Australia/Australia
    Posts
    26

    05 rxp not starting

    hey guys i did a search first but cant find what i am looking for.

    when i put either one of my keys on to start it it beeps and says key on the dash and when i push the start button it just goes tick tick tick.

    i put a new battery in about a month or so ago and have used the ski since with no problem now she no go

    any thoughts please guys?

    ta Mick.


  2. #2
    Banchy's Avatar
    Join Date
    Jul 2009
    Location
    San Juan PR
    Posts
    201

    Post engine not starting

    check the starter relay,with a test ligh or a voltimeter check the positive cable from battery (12 volts plus or less),check ground cable (-12 volts),check the cable come from starting switch to starter relay (12 volts when you push this switch).every think it's ok , change the starter relay.

  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Usualy when it says "key" it meens it is the wrong key. Ussually that wont allow it to click though.. May have a bad DESS post.

  4. #4
    like banchy said, starter reply. i had the same problem

  5. #5
    tick.. tick.. RXPteamtimebomb's Avatar
    Join Date
    Jan 2007
    Location
    Maryland
    Posts
    726
    +1
    13
    starter relay

  6. #6
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Quote Originally Posted by RXPteamtimebomb View Post
    starter relay

    +1 same for me. Check all electrical connections also.

  7. #7

    Join Date
    Jul 2007
    Location
    South Australia/Australia
    Posts
    26
    thanks for the info guys i took it in to the dealer for them to have a look at it is also bringing up a t.o.p.s fault as well just hope they can look at it today was ment to be going away this weekend

    maybe it time to update to a new ski ?

  8. #8
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Quote Originally Posted by Mick View Post
    thanks for the info guys i took it in to the dealer for them to have a look at it is also bringing up a t.o.p.s fault as well just hope they can look at it today was ment to be going away this weekend

    maybe it time to update to a new ski ?
    No you do not need to update.....you need to fix what you have, because it must be a fast machine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP Wont Start
    By RXP2 in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-09-2010, 06:14 PM
  2. Storage Removal Question For 05 RXP (dry start)
    By SpeedshifterZ06 in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-11-2009, 05:50 AM
  3. 05 Sportster not starting
    By venompwr2 in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 05-20-2009, 04:48 PM
  4. 05 RXP having starting issues
    By sfackett0 in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-13-2008, 10:18 PM
  5. First time out with stage 1 05 RXP Not happy.
    By Fastcat in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-10-2005, 09:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •