Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    can someone give me some info on 95 speedster?or 657 engines in general?

    ok i just bought a 14ft speedster in middle of winter w/out seeing running. i am good w electronics and work on all other kinda motors including snowmobile(not rotor valve) so i need a little info.the guy had replaced a motor last yr. i was given old motor also. what happened on old motor was looks like all 4 stator wires melted right from case through harness. from what i see it looks like guy who changed appeared to know what doing by looking at wiring but the 657x motor was replaced w a 657 and i seen post saying electronics different? the guy abandoned burn wires in harness and ran the 4 wires from motor right into elec box. only wire i see not being used is white.also would all the old motor need is a stator? i ask this because i also seen tag on motor(i think sbc) isnt that a reman motor?do i fix that and go back to two 657x or... not that important i didnt get to check yet if other 657x has sbc tag yet. i dont mind spending a few dollars but if it does actually run now do i leave alone or what? lol! thanks oh yeah....the motor that hasnt been touched looks liked the paint melted off top????? and should i block off injections and premix? why do i always see these needing a motor?
    Last edited by darrenz; 02-10-2010 at 05:02 PM. Reason: more info


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,273
    Welcome to the hulk

    I am not a Sea-Doo engine guy, but I can offer some info.

    SBT is indeed a company that re-manufactures PWC engines. Folks often have conflicting views on the caliber of the rebuild work, and SBT often sells on the strength of the warranty. If an SBT engine fails under warranty, they will replace it. But that is the end of the warranty, and the cost of removing the bad engine, and installing the replacement, is not covered.

    That said, some folks seem to like their SBT rebuilds just fine.

    If the engines were run without water cooling, they can get very hot rather quickly. Check for blocked water hoses, sand clogging the water jackets, kinked hoses, etc.

    Take the time to check over your 15 year old machine very thoroughly. Check every nut and bolt and fitting, and replace any original hoses that you have any suspicions about.

    Here are some PWC oriented documents that may be helpful;

    The Personal Watercraft Phenomenon

    Basic Introduction to the purchase of a Personal Watercraft
    It is written for PWC with 2-stroke engines.

  3. #3
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Your post is a little confusing but maybe we can answer one thing at at time.

    The 95 speedster used a 4 wire stator. You can not use a 5 wire stator or flywheel with a 4 wire system.

    If the MPEM was damaged then you will need to get another one & they are no longer available.

  4. #4

    thanks

    Quote Originally Posted by water worx View Post
    Your post is a little confusing but maybe we can answer one thing at at time.

    The 95 speedster used a 4 wire stator. You can not use a 5 wire stator or flywheel with a 4 wire system.

    If the MPEM was damaged then you will need to get another one & they are no longer available.

    anyone know what the white wire is that he didnt connect? all other wires are same color except the 657 has the fifth wht wire. he claimed to have paid a marine mechanic 500 to swap out....im hoping he knew how to make the 5 wire work w the 4. i called local seadoo dealer,who connected me w their "top seadoo mechanic and he told me never heard of a 657 without the x.. lol! so that wasnt much help.

  5. #5
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    If you have 5 wires coming out of the stator,it wont work.

  6. #6

    maybe im mixed up

    ok ill try to clarify the boat currently has one 657x and one 657 motor in it. the 657 is on the pass side.what happened was the 657x motor on pass side stator wires melted all the way from motor up to elec box. they bought a jetski w no title and put the 657 in.since harness was melted they drilled hole in side of elec box and wired inside. im not positive that one has 4 and one has five.... i had just noticed that a wht coming from the replaced engine is capped off. but now im thinking maybe both have four and maybe since im dealing w one computer and two engines maybe from factory one wire is not used???? i only had a brief minute to look at and now its covered in my yard in snow and 20 degrees. so im gonna have to get back in my garage and open up and look again. is this 4/5 wire deal have too do w yr? not 657 or 657x. cause now i was searching for a magneto for the 657x in my basement and had seen one w 5 wires not 4, so then i start flipping through my manual and it shows 5???? what i was orig thinking was my x had 4 and 657 had 5 because capped wire.

  7. #7
    some 650x motors had 4 wires some had 5,

    if its a 5 wire you're looking for its the same sator as the 580 yellow motors that should help your hunt.

    if you're mpems are damaged you have several options

    sad thing is that the speedster's mpems are like insanely expensive parts out of production

    you can convert it to standard mpems but it still is expensive

    open the flywheel covers and remove the flywheel to inspect your stator.

    take pictures "WE LOVE PICTURES"


    <snip>
    Random useful info.


    All yellow 580 motors & the 93 & 94 XP have the same flywheel & 5 wire stators.

    White 580's & all other 650 & 720 motors use a different flywheel & 4 wire stators.

    All 580, 657 and 720 flywheel housings and covers are the same.

    587 engine with 720 electronics will work. The only difference in mpems is the rev limiter. A 587 has a 6550 setting and a 657/717 usually are set at 7000 so you might want to add an external one you can set to the proper rpm.
    <SNIP>

  8. #8
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Quote Originally Posted by hardtarge View Post
    some 650x motors had 4 wires some had 5,

    if its a 5 wire you're looking for its the same sator as the 580 yellow motors that should help your hunt.

    if you're mpems are damaged you have several options

    sad thing is that the speedster's mpems are like insanely expensive parts out of production

    you can convert it to standard mpems but it still is expensive

    open the flywheel covers and remove the flywheel to inspect your stator.

    take pictures "WE LOVE PICTURES"


    <snip>
    Random useful info.

    All yellow 580 motors & the 93 & 94 XP have the same flywheel & 5 wire stators.

    White 580's & all other 650 & 720 motors use a different flywheel & 4 wire stators.

    All 580, 657 and 720 flywheel housings and covers are the same.

    587 engine with 720 electronics will work. The only difference in mpems is the rev limiter. A 587 has a 6550 setting and a 657/717 usually are set at 7000 so you might want to add an external one you can set to the proper rpm.
    <SNIP>
    X 2

    Just because its a 657X doesnt mean it has a 4 or a 5 wire stator,you will need to remove the flywheels on both motors to identify what stators are on there.

  9. #9
    thanks for the info .......ya next chance i get im gonna pull back in garage, open elec panel again and count wires from each motor.all i know for fact right now is... both white 657 morotrs(one is x) the striped wires were same colors coming from both motors, there is a white wire coming from 657 motor not connected, but i dont remember if there was a wht wire coming from x motor that is connected somewhere in box or not till i look again. but i think im gonna start by pulling flywheel off the x motor they removed and gave me, check compression, if good replace the melted stator in that and put back in.ill get some pics when can open up outside. my garage is a closet.

  10. #10
    well just pulled flywheel off the 657x motor in my basement.this motor has sbt sticker on so been rebuilt at one time.got about 150/140 psi out of so i pulled the magneto. which is 4 wire stator and while i was searchin ebay seemed like 657 stators were showing as 5 wire(having the wht wire i was questioning) and 657x stators were just showing 4 striped wires so i am really thinking that the 657 in the boat does have 5. also while searching i had came across something mentioning wht having something to do w rev limiting. so now i am really anxious to see if the 657 does actually fire up being everyone tells me it wont........cause now im wondering if a ski or boat w a 657x motor rev limiting is maybe being done right at mpem and a reg 657 mpem sends signal or ground etc through wht limiting at stator. heres some pics of the 657x motor they gave me removed. ever see this happen?coating had burned straight off all 4 wires???? oh ya pulled flywheel w/steering wheel puller from autozone, had 3 metric bolts even...think ill keep for 16 bucks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCI0086.JPG 
Views:	100 
Size:	258.7 KB 
ID:	172496   Click image for larger version. 

Name:	DSCI0091.JPG 
Views:	79 
Size:	229.8 KB 
ID:	172497   Click image for larger version. 

Name:	DSCI0088.JPG 
Views:	76 
Size:	164.1 KB 
ID:	172498  

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. can someone give me a part number for this???
    By Jprx21 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 12-26-2015, 09:16 PM
  2. can anyone give me an idea on 96 XP fuel consumption..PLEASE
    By vincent vega in forum 2-Stroke Performance
    Replies: 11
    Last Post: 01-06-2014, 08:40 PM
  3. Can someone give me a Canadian Yamaha PWC Conformity No.?????
    By shawnmd in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 07-26-2010, 08:48 AM
  4. Replies: 4
    Last Post: 07-13-2010, 03:34 PM
  5. Can anyone give me some advice?? on a 900ZXI
    By jarcynvicnchris93 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 04-22-2008, 07:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •