Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38
  1. #1
    KC Blue Thunder's Avatar
    Join Date
    Oct 2007
    Location
    Jacksonville, Florida
    Posts
    2,079

    Riva Open Loop Plate Coating Loss

    Heres a couple of pics of what i was talking about on a few other Riva plate threads. This loss of coating is with less tha 20 riding hrs on plate. Doels ride is much worse. Anyone else experiencing the same. Share you thoughts.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Feb 8 10 082.JPG 
Views:	101 
Size:	970.3 KB 
ID:	171784   Click image for larger version. 

Name:	Feb 8 10 083.JPG 
Views:	74 
Size:	1.03 MB 
ID:	171785  


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Did that happen after a saltwater ride? I'm asking, because I noticed that Riva didn't put any Zinc annodes on that plate. I'm thinking of drilling, and tapping my plate to add one like the stock plate has.

  3. #3
    KC Blue Thunder's Avatar
    Join Date
    Oct 2007
    Location
    Jacksonville, Florida
    Posts
    2,079
    Quote Originally Posted by psycho rxp View Post
    Did that happen after a saltwater ride? I'm asking, because I noticed that Riva didn't put any Zinc annodes on that plate. I'm thinking of drilling, and tapping my plate to add one like the stock plate has.
    I ride on every type of water: spring fed, brackish, and salt. This is not corrosion its loss of coating. I know it looks like pitting corrosion but it aint, there is no corrosion residue.

  4. #4
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    This is disappointing. I hope I have different results.

  5. #5
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    All my coating blew right off.......
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	riva rideplate 002.jpg 
Views:	151 
Size:	503.9 KB 
ID:	171808  

  6. #6
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by speedskixp View Post
    All my coating blew right off.......

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by speedskixp View Post
    All my coating blew right off.......

    Jim, did you mod the plate some or just remove some of the finish?

    On another note, I really dont know why they painted or finished the plate as that is not going to stay IMO.

  8. #8
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by skoepp View Post
    Jim, did you mod the plate some or just remove some of the finish?
    He's sanding it down to paint it pink to match his new paint scheme ...

  9. #9
    Quote Originally Posted by speedskixp View Post
    All my coating blew right off.......
    Warp speed run?

  10. #10
    Doel Tiburon1264's Avatar
    Join Date
    Nov 2007
    Location
    Jacksonville, Florida
    Posts
    2,343
    +1
    11
    Quote Originally Posted by bigdaddyRXP View Post
    He's sanding it down to paint it pink to match his new paint scheme ...
    Now thats funny shit! ... U guys know this is a really important thread. Kc is trying to get a point across the forum about this plate and you 2 R messing it up for him....................

    LMAO!!!!!!!!!!!!!!!!!! Pink is a great color for JIM.....

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RIVA Open loop plate w/closed loop cooling!
    By dduck1628 in forum 4-Tec Performance
    Replies: 173
    Last Post: 04-07-2014, 12:01 PM
  2. Riva open loope plate ?
    By rjr in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-18-2010, 06:18 PM
  3. Riva Open Loop plate on RXT
    By piper250 in forum 4-Tec Performance
    Replies: 34
    Last Post: 09-21-2009, 11:07 PM
  4. Riva open loop plate results.....
    By rxpblast in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-13-2009, 10:00 PM
  5. Riva open loop plate, porpoising now
    By dduck1628 in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-11-2009, 11:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •