Results 1 to 2 of 2

Thread: Riva Open Loop

  1. #1
    ou812's Avatar
    Join Date
    Jun 2006

    Riva Open Loop

    Anyone have any issues yet?

    How are the IC's holding up to the OL? Is there more pressure going through them?


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    venice fl.
    Mine's working great without any issues at all. The pressure is pretty much the same as stock with the thermo closed and less when the thermo is opened. One thing I did notice is a slighly different exhaust tone from the slightly drier ehaust when the thermo opens but no issues from it at all after 100+ miles of hard riding alot of wich was wot. It's truly a great kit.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. installing open loop??? help
    By islandboy in forum 4-Tec Performance
    Replies: 60
    Last Post: 07-18-2008, 11:09 PM
  2. Open Loop Cooling setup.
    By boostaholic in forum Conversion PWC Performance Skis
    Replies: 3
    Last Post: 01-16-2008, 09:11 PM
  3. open loop cooling
    By allairch in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-09-2007, 09:57 PM
  4. switching from closed loop to open loop!
    By beachboy66 in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-16-2007, 01:04 AM
  5. Open loop / closed loop
    By Lvnspeed in forum 4-Tec Performance
    Replies: 4
    Last Post: 01-25-2007, 01:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts