Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709

    click click then start

    well just went out and tried to start the ole rxt and i get 2 or 3 clicks before she starts on the next try. could this be the start button or the relay? thanks in advance.


  2. #2
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    battery?

  3. #3

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    Quote Originally Posted by jpeconsult View Post
    battery?
    oh,, forgot to say battery is fully charged showing 12.5 v on my battery tester

  4. #4
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,899
    +1
    507
    Quote Originally Posted by busa504 View Post
    well just went out and tried to start the ole rxt and i get 2 or 3 clicks before she starts on the next try. could this be the start button or selinoid? thanks in advance.
    Most likely the solenoid if you have never replaced it before but first check and clean all the connections!

  5. #5

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    Quote Originally Posted by oklagp1200r View Post
    Most likely the solenoid if you have never replaced it before but first check and clean all the connections!
    well i looked at it and it appears to be clean. it is an 06 rxt never changed it before.. and the relay went underwater 2 times.

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    The solenoid is known to fail. I always keep a spare handy.

  7. #7

    Join Date
    May 2008
    Location
    metairie,la
    Posts
    709
    Quote Originally Posted by beerdart View Post
    The solenoid is known to fail. I always keep a spare handy.
    well i am going to get one, the oem parts finder calls it the relay.. same thing i guess?? is that the right part to order?

  8. #8
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    Quote Originally Posted by busa504 View Post
    well i am going to get one, the oem parts finder calls it the relay.. same thing i guess?? is that the right part to order?
    Yep item #20

    SKU: 278001802
    Starter Relay 1 $31.59

  9. #9
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    Yes , as far as I know, it's called a relay by BRP

  10. #10
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Busa, I just ordered one myself. Apparently, when removing the engine and you leave the power cable on the starter, it rips the solenoid/relay in 1/2.

    I don't know why my "lessons learned" are so expensive!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 ultra 150 click when start pressed
    By Khigh402 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 9
    Last Post: 07-25-2015, 04:29 PM
  2. Clicks when start button is pushed
    By leedanger in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 09-12-2012, 10:09 AM
  3. Click click click x9 then start. 05 RXT
    By e92oholic in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-23-2012, 03:48 PM
  4. Replies: 3
    Last Post: 02-22-2012, 07:52 AM
  5. 900ZXI one click- no start
    By deka in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 09-10-2008, 05:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •