Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: VTS Problems

  1. #1
    I love water's Avatar
    Join Date
    Jan 2010
    Location
    High Rock Lake
    Posts
    252

    VTS Problems

    Here's what I have. A 95 xp800 I have replaced the following

    Trim motor
    switch
    module

    Is there a way to straight wire it some how? I don't understand why seadoo made it so hard.

    I am just wanting it ti be simple?

    Isn't there something in the front electronic box that controls it?


  2. #2

    Join Date
    Jul 2008
    Location
    Southeast Texas
    Posts
    101
    I'm not sure what you mean by "straght wire" ,but, no, it is designed about as simple as it can be, and still work. If you replaced all those parts, it should work. the most common problem with the VTS is the box that contains the limits switches and reversing relay gets wet internally and shorts out the relay. The box is sealed, but, the potting or the o-ring on the output shaft can go bad allowing moisture in.
    Robert V

  3. #3
    I love water's Avatar
    Join Date
    Jan 2010
    Location
    High Rock Lake
    Posts
    252
    Whats to replace next?

  4. #4
    I love water's Avatar
    Join Date
    Jan 2010
    Location
    High Rock Lake
    Posts
    252
    Is there something in the front electronic box that controls it?

  5. #5
    I love water's Avatar
    Join Date
    Jan 2010
    Location
    High Rock Lake
    Posts
    252
    No one knows what i am talking about?

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Did you check for a fuse?? Or a bad connector/connection..

  7. #7

    Join Date
    Jul 2008
    Location
    Southeast Texas
    Posts
    101
    Did you check the handlebar switches and their connectors?
    What exactly is it doing? Do you hear a "click' when you press either the up or down switch?
    Give us a little more info. maybe we can help you.
    robert V

  8. #8
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by s/d-daddy View Post
    Did you check the handlebar switches and their connectors?
    What exactly is it doing? Do you hear a "click' when you press either the up or down switch?
    Give us a little more info. maybe we can help you.
    robert V
    +1

    The 7.5 amp fuse controls the motor, it's in the rear black box. The module's powered though the front gray box.

    As Robert said above, give us specifics about what it is doing.

  9. #9
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Quote Originally Posted by I love water View Post
    Here's what I have. A 95 xp800 I have replaced the following

    Trim motor
    switch
    module

    Is there a way to straight wire it some how? I don't understand why seadoo made it so hard.

    I am just wanting it ti be simple?

    Isn't there something in the front electronic box that controls it?

    welcome to the forum, try this link below....maybe it can assist some

    http://www.sea-doo.net/techarticles/vts/index.html

  10. #10
    I love water's Avatar
    Join Date
    Jan 2010
    Location
    High Rock Lake
    Posts
    252
    I don't have a 7.5 fuse I have 15's in the rear box. Where is the 7.5 spose to go?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VTS Problem - Pulling to the Left when Trimmed up 100%
    By ImAcoustic in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-17-2008, 02:11 PM
  2. 97 xp vts problem
    By punchtech in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-21-2008, 07:15 AM
  3. 97 xp vts problem
    By punchtech in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-20-2008, 11:28 AM
  4. VTS problem
    By rxpiowa in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-12-2008, 12:34 PM
  5. vts problem
    By Swedie in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-28-2008, 12:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •