Results 1 to 6 of 6
  1. #1
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    chesapeake Va.
    Posts
    270

    785 wear ring question

    hey guys i finally got the black piece separated from the stator (only took 3 weeks ). looks like the wear ring is pretty worn in one spot and corrosion has caused the ring to raise up a bit in one spot (here are pics). i guess my question is is there a way or place where i can just purchase the wear ring and replace it? or do i need to buy the whole part?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00831.JPG 
Views:	26 
Size:	3.15 MB 
ID:	172742   Click image for larger version. 

Name:	DSC00834.JPG 
Views:	28 
Size:	3.11 MB 
ID:	172743   Click image for larger version. 

Name:	DSC00833.JPG 
Views:	28 
Size:	3.09 MB 
ID:	172744  


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Jeff,
    Thats scrap contact John Zigler on here he shows 2 nice ones forsale on his site
    He a Great guy to deal with

  3. #3
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    chesapeake Va.
    Posts
    270
    Quote Originally Posted by 785 lugs View Post
    Jeff,
    Thats scrap contact John Zigler on here he shows 2 nice ones forsale on his site
    He a Great guy to deal with
    what is his website?

  4. #4
    thester71's Avatar
    Join Date
    Jun 2009
    Location
    central ma.
    Posts
    1,698
    check out your extension it probably has the same bump, the pump on my pro had the same damage, I was told it was from running it in salt water.

  5. #5
    thester71's Avatar
    Join Date
    Jun 2009
    Location
    central ma.
    Posts
    1,698

  6. #6
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    chesapeake Va.
    Posts
    270
    Quote Originally Posted by thester71 View Post
    unfortunatly i dont have the original extension. and yes this thing was ran and sat in salt water for a very long time. i have rebuilt everything now except the cables and the hull!!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 785 pro installing wear ring question
    By skigolfnut in forum Polaris Open Discussion
    Replies: 3
    Last Post: 02-23-2014, 12:11 PM
  2. wear ring question?
    By qbzonk in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 04-24-2007, 07:11 AM
  3. Wear ring question
    By NJ-Ski in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-16-2006, 12:47 PM
  4. wear ring questions
    By DSquare in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-29-2006, 07:43 PM
  5. SS wear ring question...?
    By GeoRXT in forum 4-Tec Performance
    Replies: 14
    Last Post: 04-18-2006, 11:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •