Results 1 to 7 of 7
  1. #1
    VegasRatt's Avatar
    Join Date
    Sep 2006
    Location
    Sin City
    Posts
    250

    Triumph Over Genesis Problems

    This is a post I had place at "the other place" and felt I should move it over here. It is great to have found everyone again.

    I have finally triumphed over my Polaris Genesis FFI’s chronic problems with it cutting out inconsistently all the time and running so very poorly. The machine now runs better than it ever has and flat runs like a bat out of hell. Finally. For those of you who have been keeping track and helping out thanks a million for all your help with this thing. The fix came in two parts. First, I was able to get a hold of my own WRENCH so that I could check everything out and fix any computer related issues and adjust my TPS. Second, was the TPS connection itself. I have read a number of time where ph20craft has said the crimp that sucker down with needle nose pliers and never did it until now. I could see with the WRENCH what he was talking about in signal changes with vibration….. Anyway she now runs great.
    I want to give an extra thanks to ph2ocraft, Bernie, and 2stroker for all your advice. If you guys ever need anything please let me know……………
    <DIV>__________________
    <FONT face=Arial><FONT color=black>>VegasRatt


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Vegas, it's awesome you're up and running and at least you get a little cruising time before the weather bites.

  3. #3
    Altron's Avatar
    Join Date
    Sep 2006
    Location
    Klamath Falls, OR
    Posts
    91
    Vegas, great to hear that you got it up and running. I will hopefully have my MSX150 up and running tomorrow when my new System Interface Board shows up. How did you go about getting your own WRENCH? I have been thinking of making the investment myself since my dealer is 300 miles away and I like working on my own equipment.

    Altron

  4. #4
    VegasRatt's Avatar
    Join Date
    Sep 2006
    Location
    Sin City
    Posts
    250
    Hey ph2ocraft, you make it sound like we don't ride in the winter. Heck I have a 4/5mm Body Glove wetsuit and will be in the water alot. oh, and where did you get that avater? That is GREAT!!!!!

    What's up Altron, sounds like you are about ready to go. I couldn't find a dealer within 400 miles with the wrench but I was lucky enough to find one online at PWCToday who sold me the cables and a "demo" version of the wrench. If you need any help let me know.

  5. #5
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Hmmmnnn true, Vegas is still plenty perfect isn't it??

    I figured with all of the triple piped boats I have, my avatar should be tripled as well.....

    We are going to ride from Laughlin to Havasu for the races, up for a little cruise??

  6. #6
    VegasRatt's Avatar
    Join Date
    Sep 2006
    Location
    Sin City
    Posts
    250
    Absolutely!!!!!! give me the details, i'm up for a good run like that.

  7. #7
    Altron's Avatar
    Join Date
    Sep 2006
    Location
    Klamath Falls, OR
    Posts
    91
    Hey Vegas, If you could help me out with how to get the wrench and a cable that would be awesome. I have a 2004 MSX150.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1300R only 30 hours over heating problem
    By hockey061890 in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 08-17-2011, 11:18 PM
  2. where do i start,with a shotgun?? ha-ha...genesis problem
    By bighad in forum Polaris Open Discussion
    Replies: 25
    Last Post: 08-12-2010, 11:11 PM
  3. 1200 genesis problem
    By pipp in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 06-18-2009, 03:04 PM
  4. What Is Causeing My Over Heating Problem???
    By xBigDaddyx117 in forum 4-Tec Performance
    Replies: 57
    Last Post: 02-03-2009, 06:53 PM
  5. 05 gpr .. over heating problem??
    By hispeed in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-07-2007, 05:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •