Page 1 of 7 1 2 3 ... LastLast
Results 1 to 10 of 62
  1. #1

    New Member Needs Help.

    i just bought 96 polaris 900 sl and i have no spark and wont start any ideas


  2. #2
    anyone with any idea as to what might cause this can u reply to me at jessica_rabbit[email protected] thank for any help

  3. #3
    rlharrison60's Avatar
    Join Date
    Aug 2007
    Location
    Orange, Texas
    Posts
    1,091
    +1
    1
    Time for the stator upgrade kit.

  4. #4

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    how many volts on the battery while cranking ? do not use the gauge on the ski

  5. #5

  6. #6
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    welcome to the forum

  7. #7

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,579
    +1
    1,272
    Welcome to the Hulk

    Click below and follow the links for the red Domestic engine

    10.5 volts at the battery is not enough. Replace the battery.

  9. #9

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    its not that easy but it might be , replace the battery , clean the plugs or install new ,

    what plugs are you running , you have to have resistor plugs as well

  10. #10
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    also make sure where the plug wire meets the boot is not corroded.. this might not be the issue on all three plugs but you should check any way.. i had this happen too my sl1050 but you are probebly looking at a stator update kit.. just put one in my ski..380 plus shipping

Page 1 of 7 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Member Needs Help.
    By Frozen in forum Polaris Open Discussion
    Replies: 23
    Last Post: 10-24-2009, 07:12 PM
  2. New member needs help (Carbs)
    By Torque in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-10-2009, 09:48 PM
  3. new member need help!!!!
    By rxpredviper in forum 4-Tec Performance
    Replies: 23
    Last Post: 04-19-2009, 06:16 PM
  4. A fellow gh.net member needs help
    By tomgtv in forum Open Discussion
    Replies: 0
    Last Post: 08-02-2006, 03:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •