Results 1 to 5 of 5

Thread: Odyssey Battery

  1. #1
    Texan78's Avatar
    Join Date
    Feb 2010
    Location
    N. Texas
    Posts
    395

    Odyssey Battery

    I just picked up a new Odyssey Battery for my 1996 1100 ZXi. I want to make sure I got the correct one. I got the PC545-P as that is the one it was saying I needed. The guys at the store were getting a different part number. They said it would work but the posts were reverse on the one I got. The one I got wasn't showing up as the one I needed. So I am just curious if I got the correct battery?

    Ok now for the dumb question. When I got this ski the neg battery cable was just laying in the hull. I have looked in the manual but it doesn't say where the other end of the cable is suppose to be mounted. Shows it in the diagram but doesn't say where it needs to go. So could anyone tell me where the neg. cable needs to be mounted in the hull on the 1100 ZXi 96?

    -Thanks


  2. #2
    Moderator DrewNJ's Avatar
    Join Date
    Dec 2005
    Location
    Marlton, NJ
    Posts
    3,716
    +1
    1
    I'm fairly certain you'll be fine with the battery as long as your wire configuration bolts up and the battery physically fits.

    As for the ground cable they usually go under one of the mounting bolts that hold the starter to the side of the motor. Any solid motor bolt/case bolt will be fine.
    Doug

  3. #3
    Texan78's Avatar
    Join Date
    Feb 2010
    Location
    N. Texas
    Posts
    395
    Ok thanks, it does fit and everything connects as it should.

    Now for the other problem. When I first turn the ski on shouldn't the lights self test and come on for a few seconds? Mine do not do anything but I am getting power because when I hit start I can hear the starter relay and the trim relay with I hit the trim. None of the gauges seem to be working though and the dummy lights are brand new. I have the ground wire from the harness grounded to the battery and nothing. Even tried ground it to a bolt. The more is out right now but I don't think that would matter. Checked the fueses and they are good too.

  4. #4

    Join Date
    Jan 2007
    Location
    Houston, TX
    Posts
    155
    You say that the terminals on the battery you purchased are reversed. Are you sure that the neg cable is connected to the neg Battery post and the pos cable is connected to the pos battery post?
    just a thought.

  5. #5
    Texan78's Avatar
    Join Date
    Feb 2010
    Location
    N. Texas
    Posts
    395
    Quote Originally Posted by ki5pm View Post
    You say that the terminals on the battery you purchased are reversed. Are you sure that the neg cable is connected to the neg Battery post and the pos cable is connected to the pos battery post?
    just a thought.
    Yes they are connected correctly. The posts are on the right sides, the guys at the store were wrong. When they meant by reverse they were telling me the pos. should have been on the left and not the right. Red is positive, black is negative.

    I am about out of ideas. I have worked on this all day and can't find out what the deal is.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Odyssey Battery?
    By ujustlost in forum Polaris Open Discussion
    Replies: 1
    Last Post: 04-05-2010, 11:10 PM
  2. odyssey Battery
    By Kinchyle in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-24-2008, 09:52 PM
  3. Odyssey Battery for Ultra 250x?
    By GUTCH in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 04-21-2008, 11:24 PM
  4. Odyssey Battery fitment in U250X
    By earthshaker in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 11-06-2007, 02:00 AM
  5. Odyssey Battery
    By Pale Rider in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-30-2006, 10:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •