Results 1 to 10 of 10
  1. #1

    02 RX-DI rave valve

    Is anyone aware of this happening?

    I have an 02 RX-DI that it seems the sliding valve of the Rave Valve has come into contact with the top edge of the piston and upper piston ring. Does anyone know why this would happen and the fix so it would not happen again after the repair is made?

    Thanks,
    Michael


  2. #2
    4.0l sahara's Avatar
    Join Date
    Jul 2009
    Location
    shelton ct
    Posts
    445
    was it bored out and rebuilt? When going over a certain size they need to be ground down.

  3. #3
    No engine work has been done. I purchased it new.

  4. #4

    Join Date
    Jul 2005
    Location
    Ohio
    Posts
    441
    +1
    1
    take some pics of what you see and post them here

  5. #5
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    take the head off and remove the rave valve cap off and push the valve closed into the piston, and see if you need to trim some off, also check your rave to check and make sure is not cracked.

    Most likely you will need to replace the piston if its damaged dont take a chance it scoring your cylinder walls, check your compression, since you're at it, wont hurt to just do a new top end.

  6. #6
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Perhaps the RAVE blade has come loose from the nut?

    Unless the engine was rebuilt with oversized piston big enough to need a blade re-sizing that is about the only possible explanation.

  7. #7
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    this is really weird,

    when I bought my XPL the rave valve was chipped in the middle,
    but the engine was blown, so I do not know if this was the cause.

  8. #8
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    If your piston was broken up a piece of it may have struck the valve.

  9. #9
    I was able to see the damage to the piston through hole that the rave valve is installed. The top edge and the top ring groove of the piston has collapsed.
    Time to start tearing it down to see what I will need for the repair.

    Thanks to all for your input.

  10. #10
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Note that if a ring spun the damage would be in the same place as if it struck the valve. When you get the piston out look for the gap in the upper ring. If you can not find it the ring spun and caused the problem to begin with.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 rx di 59mph GPS
    By Mtuned in forum 2-Stroke Performance
    Replies: 8
    Last Post: 10-09-2011, 12:23 AM
  2. Replies: 2
    Last Post: 08-21-2011, 12:03 PM
  3. WTB Motor for a 02 RX DI 951
    By onefastgpr619 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 05-10-2011, 06:24 PM
  4. 951 DI Rave Valve issues............
    By philip clemmons in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-13-2010, 06:24 PM
  5. 2001 951 DI RAVE valve issue
    By race24x in forum 2-Stroke Performance
    Replies: 5
    Last Post: 07-11-2010, 03:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •