Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31
  1. #1
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1

    New RR IC still not helping, any ideas ????

    Took the boat out with the PPG repitch and the boat is still on the rev limiter. I did pick up some speed. Previous Radar runs were 68-69 all day (115 degree heat index). Today it was cooler and I made one pass at 72.7 the rest were 71+ most every time.
    The boat still does not accelerate like I would like, I believe the prop is spinning on the bottom a little now. Do you think more pitch is in order?
    From the last prop pitch it helped a little but nothing spectacular. There is just nowhere near enough midrange pull.

    I thought about the pump cone spacer to load the motor a little more or just send the prop back to PPG?

    I now have the repitched 14/19 which way would you guys go?
    The boat hit harder before the IC, now the prop just seems way off.

    Temp was 92 heat index was 97 water temp was 89

    Thanks

    David


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,997
    +1
    1,903
    David, those don't seem to be bad numbers at all. You are still running the stock ECU right?

    I think you need to have your prop fine tuned a little more.

  3. #3
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1
    Yes stock ECU, top speed is not bad just the midrange and bottom end.
    It just seems the boat has a lot more to give

    So you think just more pitch?

  4. #4
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1
    Also do I want to be on the limiter?
    Since I am now, does it not make since that it is underproped?

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,997
    +1
    1,903
    David, if you are spinning out of the hole you need to have the prop tweaked. They can tweak it to give you a little more midrange too.
    Sometimes it takes several tries to get that magic pitch on the prop.

    Hmmmm, i wonder what one of those new Solas 15/20 impellers would do on your setup. It would be very interesting to see.

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,997
    +1
    1,903
    Also, being on the limiter is not like being on the limiter on the RR Ecu.
    On the stock ECU you WANT to be on the limiter. Hopefully you are seeing a solid 8100? Maybe 8150? If you are that is GREAT!!! Especially in this heat.

  7. #7
    What harm does it do if you always hit the rev limiter? Can the stock ECU be reprogram for a higher limiter? I know that would void warranty but with all the major mods you dont have a warranty anyway.

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,997
    +1
    1,903
    It does no harm to run against the limiter on the stock ECU. In fact, you want to get as high of RPM as you possibly can with that ECU. Unfortunately the stock ECU is not programmable to adjust the rev limit.

  9. #9
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1
    Yes it is 8100-8150 all the time, would you change the top end of the prop, or leave it alone? In other words try to gain more speed or do you think I am there?

    More pitch on the bottom will be great. It does seem to hit harder out of the hole than before but @ 5000 rpm's or so it looses its pull.

    I will call PPG tomorrow about a prop pitch again.

    The 15/20 would be harder to turn correct?

    I may give that a try.

  10. #10

    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    128
    Skippy and I have determined if you are on the limiter all the time with RR cam and RR ECM the valves are floating and you will hit the pistons with the exhaust valve and they will break off. I wouldn’t be running a thinner head gasket either.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 Virage Will Not Run. Any Ideas?
    By Jeffery73 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 01-29-2013, 10:40 AM
  2. Msx 150, new wastegate and still not working
    By lopezmabin in forum MSX/Matrix
    Replies: 4
    Last Post: 05-29-2011, 11:55 AM
  3. Need help any ideas 07RXP
    By 1fast07RXP in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-14-2009, 11:00 AM
  4. Help – Any Ideas?
    By mtench in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 07-15-2007, 03:37 PM
  5. HELP, any ideas?
    By sands in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 04-01-2007, 07:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •