Results 1 to 6 of 6
  1. #1
    Banned User
    Join Date
    Nov 2009
    Location
    Thessaloniki
    Posts
    36

    Open loop and ride plate help

    Before i fitting to my jet the open loop and the ride plate my engine runs 8400rpm with the x charger rotax intercooler 42 injector big fuel pump 4,2bar head porting riva valve train upgrad kit 70c thermostat trottle body 61mm adjustable pump cone Pump Wedge and the top speed was 80mps sea water i put the open loop and the plate and my jet runs 8630rpm but the top speed is only 71mps what do you thing is the problem.I check the ride plate installation and is ok also the grade.The speed is the same with the trim up and meddle.


  2. #2
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62
    Quote Originally Posted by kiriazidis View Post
    Before i fitting to my jet the open loop and the ride plate my engine runs 8400rpm with the x charger rotax intercooler 42 injector big fuel pump 4,2bar head porting riva valve train upgrad kit 70c thermostat trottle body 61mm adjustable pump cone Pump Wedge and the top speed was 80mps sea water i put the open loop and the plate and my jet runs 8630rpm but the top speed is only 71mps what do you thing is the problem.I check the ride plate installation and is ok also the grade.The speed is the same with the trim up and meddle.
    WOW

    8630 rpm with 42 injec if am you i do a compretion test first ..

  3. #3
    Doel Tiburon1264's Avatar
    Join Date
    Nov 2007
    Location
    Jacksonville, Florida
    Posts
    2,343
    +1
    11
    I will throw in a set of 50lbs injectors! What the Boost numbers? I would completed a cylinder leak down test or compression test. Do you check the rideplate and grate after the testing/run................

  4. #4
    Banned User
    Join Date
    Nov 2009
    Location
    Thessaloniki
    Posts
    36
    I don't have power problem the engine run perfect 13psi the compressor 8600rpm the problem i thing is somewhere at the pump set up with the plate but i don't know what.I check the plate after the test and it was ok.

  5. #5
    sp_RXP_GR's Avatar
    Join Date
    Oct 2007
    Location
    Greece,Athens
    Posts
    148
    What ecu are you running???

  6. #6
    Banned User
    Join Date
    Nov 2009
    Location
    Thessaloniki
    Posts
    36
    Australia 8650

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Open loop and Ride plate...
    By NOONZ in forum 4-Tec Performance
    Replies: 42
    Last Post: 07-31-2013, 02:55 PM
  2. will ride plate help power on take off and planing out?
    By Firewalker918 in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-19-2012, 09:12 AM
  3. Intake Grate and ride plate - now im slower!!! HELP!!!
    By jcorallo in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 07-09-2007, 10:59 PM
  4. Ride Plate HELP!! and some other stuf....
    By jsc7002 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 07-07-2007, 04:25 PM
  5. Yet another ride plate help thread (riva)
    By FSTGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 07-06-2006, 05:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •