Results 1 to 2 of 2
  1. #1

    Post XPDI 2003 Fuel pressure

    hi, i have an XPDI 2003, since i got it i have had problems getting any speed before the warning lamp comes on and goes into limp mode.
    i have been working through the manual and found that the Fuel pressure before cranking is 24/25 PSI which is ok, but when cranking it only reaches about 60psi (should be 107 psi), i checked the fuel pump and it reached over 107 psi no problem, so what do you think the next step should be? i was thinking the air regulator may need replacing? i havn't tested the air compressor its self as i dont have the fittings to do so, but i removed the head of the compressor and all looks fine. any ideas?


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by moary123 View Post
    hi, i have an XPDI 2003, since i got it i have had problems getting any speed before the warning lamp comes on and goes into limp mode.
    i have been working through the manual and found that the Fuel pressure before cranking is 24/25 PSI which is ok, but when cranking it only reaches about 60psi (should be 107 psi), i checked the fuel pump and it reached over 107 psi no problem, so what do you think the next step should be? i was thinking the air regulator may need replacing? i havn't tested the air compressor its self as i dont have the fittings to do so, but i removed the head of the compressor and all looks fine. any ideas?
    Bro, before you pull your hair out anymore check the charging system and make sure the battery is good and fully charged. They are very sensitive to low voltage wich is likely why your pressure is low while cranking. I had a 03 rxdi and xpdi. The rxdi di exactly what you are saying. If I charged the battery before hitting the water it would run full speed for the first 10-15 min but after that would get the pesky beep and limp mode as soon as I tried to apply more than half throttle or so. Ended up being the voltage reg and was a simple fix.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 virage 1200 TXi, no spark/ fuel pressure
    By jimmyg in forum Polaris Open Discussion
    Replies: 14
    Last Post: 09-12-2016, 01:06 PM
  2. 2003 MSX 140 fuel pressure test, no pressure reading
    By Lathegreat1189 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-14-2016, 01:00 PM
  3. Installing Fuel Pressure Regulator
    By Red Devil in forum 4-Tec Performance
    Replies: 8
    Last Post: 12-17-2007, 09:19 PM
  4. fuel pressure regulator
    By Pale Rider in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-26-2006, 06:23 PM
  5. Fuel pressure regulator
    By Pale Rider in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-11-2006, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •