Results 1 to 2 of 2
  1. #1

    Join Date
    Mar 2010
    Location
    Christchurch New Zealand
    Posts
    1

    Exclamation 701 raider backfiring thru crank seal

    Hi all.
    Can anyone share some insight on this problem?
    My {usually} trusty raider has just started backfiring thru the pto end crank main seal - only on over run. You can hear & see a puff of gas burping out of the seal on over run. I also note that the usually rock steady idle has become rough and unreliable.
    Is this a reed valve issue or a seal issue or something else?
    Has this happened to anyone else?


  2. #2
    krispaintballz's Avatar
    Join Date
    Sep 2007
    Location
    Kenosha, WI
    Posts
    2,978
    Backfiring is usually a timing problem. But you might just have had a crank seal come loose. Split the cases check everything over and just get some new seals.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 701 pto crank seal is it good or bad
    By windjammer in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 08-24-2010, 05:20 AM
  2. Raider 1100 Rear Crank Seal Replacement - Help, Please
    By jasond32 in forum Yamaha Old School Skis
    Replies: 12
    Last Post: 06-21-2010, 03:27 PM
  3. Replies: 7
    Last Post: 09-21-2009, 05:05 PM
  4. 701 raider question
    By one freaky 1300 in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 05-24-2007, 01:41 PM
  5. crank seals
    By John in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 01-28-2006, 01:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •