Results 1 to 8 of 8
  1. #1

    Join Date
    Jan 2008
    Location
    bryan college station, tx
    Posts
    259

    ultra 150 not getting fuel

    I can prime the carbs and it will fire. But even with the choke closed it will not pull fuel through the fuel filter. Filter in the tank or bad pump. I cant find anywhere on how the fuel system works on the ultra 150's


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281

    it's your basic vac system

    if the fuel filter isn't stock take it out and retry. Automotive filters can restrict flow.

    check to see that the pumps are getting enough vac from the pulse line

    try with tank cap off, tank venting system may be screwed

    I'm assuming after you prime the carbs the engine runs?..or it's not pumping fuel at all?

    more details helpful

  3. #3

    Join Date
    Jan 2008
    Location
    bryan college station, tx
    Posts
    259
    i stated that if the carbs are primed then it will run until the fuel runs out. Its not getting fuel period. The fuel filter is a stock ultra 150 filter. The fuel filter is fine though.

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281

    cheking fuel flow

    is a painful and sometime dangerous process. Tank work on the u 150 is no fun at all.

    So if I understand what's up here..if you prime the carbs no problem tillt he tank runs dry or you shut off?..or after a couple of seconds it dies

    The simplest way is to connect the fuel inlet line to a gas can and see if it can pull fuel from a separate source. Lots of caution needed here.

    I use an old motorcycle tank to deal with this sort of thing, but you can run a few feet of line into a gallon gas can and it will get the job done.

    If you can't pull gas from the can, then the carbs are going to have to come off and the fuel pump replaced. I recall that no fuel pump parts are supplied, they sell it as a unit only.

    Might be wrong for all ultras, the ones I had dealing with had CV carbs. I know some had direct control slides.

    if you can pull gas from a can, then you likely have a bad petcock, again a pain as the petcokc is pricey and runs by cables to the top of the fuel tank.

    before you do anything check to make sure the valve is actually turning when you work the fuel selector on the hull.

    I had a stiff one that kept breaking the fuel selector knobs. A real pain in the ass for sure.

    In any event, you need to check the tanks vents and I'd suggets a regular system pressure check to be sure everything is in order before buttoning it up and riding it.

  5. #5

    Join Date
    Jan 2008
    Location
    bryan college station, tx
    Posts
    259
    i feel so stupid. i didnt even turn the fuel on. I guess during the winter i forgot how to start a jetski....geez! Thanks though cause until you said anything about the petcock. I wouldnt have even thought about it.

  6. #6
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Roflmao..... Sometime you just have to remember the kiss principle

  7. #7

    Join Date
    Jan 2008
    Location
    bryan college station, tx
    Posts
    259
    i know. I told my wife and she just laughed at me. I turned the fuel on and she fired right up. Im shooting for 69 this year. Finished last year with a 68.0 twice in a roll.

  8. #8
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    I have to admit I went out once and my 04 was running like crap couldnt figure it out so I went home. Got to checking it out and figured out I had left the choke half on

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 550sx Not Getting Fuel
    By skirunner2486 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-20-2011, 08:48 AM
  2. Gpr not getting fuel from sending unit, new lines installed
    By waverider1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 54
    Last Post: 02-18-2011, 04:25 AM
  3. Yamaha not getting fuel
    By tthimlar in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 10-07-2010, 08:52 AM
  4. 1992 sl 650 carbs not getting fuel, stumped???
    By hoopduerr in forum Polaris How To & FAQs
    Replies: 23
    Last Post: 08-16-2010, 01:32 PM
  5. 97 1100 venture not getting fuel??
    By score602 in forum Yamaha Old School Skis
    Replies: 7
    Last Post: 07-10-2010, 08:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •