Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 44
  1. #1
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77

    exhaust install pics

    Ibadton and myself installed my Waterbox and tip yesterday. We ran in to a few issues but have most of them addressed now.

    I still need to sort out my water routing between my strainer and IC. I have mine setup like his now but we did not have a chance to connect it all up.

    I did fire it up for a second and DANG!!! He hit the throttle and I jumped about 3 feet. I heard a beep so I shut it off immediately.

    Im assuming it was an exhaust temp alarm since no water was flowing.

    Here are some pics.


  2. #2
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77

    more pics

    Skoepp, can you give me a buzz when you read this please? I will PM you my number.

  3. #3
    Project_X's Avatar
    Join Date
    Dec 2009
    Location
    Miami
    Posts
    162
    Ocman not to go off topic but I could nt help but notice your fiberglass strains. on your pump tunnel. did anything happen to caused that? I ask only because I have the same thing exactly. My theory to what caused mines was a 10mm socket left in the hull by accident.

  4. #4
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    It could be bro. I do think I have a tool or two in the bottom that I need to get out before I hit the water.

    Even Ibadton asked about that yesterday because he had a big piece of fiberglass stab him in the hand. It looks to me like it came this way from the factory though

  5. #5
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77

    Video

    Ok, I hooked up all the hoses and put some water to it and all seems well for now. Just got to tidy things up and install the block offs when Jerry sends them.

    I hope they are still on schedule. The vid is from my droid so its not great.


  6. #6
    Project_X's Avatar
    Join Date
    Dec 2009
    Location
    Miami
    Posts
    162
    Quote Originally Posted by Ocman View Post
    It could be bro. I do think I have a tool or two in the bottom that I need to get out before I hit the water.

    Even Ibadton asked about that yesterday because he had a big piece of fiberglass stab him in the hand. It looks to me like it came this way from the factory though
    I caint seem to find that dam 10mm socket though that shit is lost lol,any who it sounds sick man i bet at wot it will sounds like a frieght train coming thru.

  7. #7
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Quote Originally Posted by Project_X View Post
    I caint seem to find that dam 10mm socket though that shit is lost lol,any who it sounds sick man i bet at wot it will sounds like a frieght train coming thru.
    Tip the ski up, if it doesnt roll to the back then its stuck under the motor. I use i a magnet thats on a tv antena from a dollar store to reach under the motor to get sockets i drop.

  8. #8

    Join Date
    Mar 2007
    Location
    united arab emirates; abu dhabi
    Posts
    98
    +1
    1
    Quote Originally Posted by Ocman View Post
    Ok, I hooked up all the hoses and put some water to it and all seems well for now. Just got to tidy things up and install the block offs when Jerry sends them.

    I hope they are still on schedule. The vid is from my droid so its not great.

    goooooooooosh i really miss that sound!! anyway i got an fzr now

  9. #9
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77

    Re: exhaust install pics

    I pulled a 1/2 out yesterday while i had it tipped up.

    Sent from my Droid using Tapatalk

  10. #10

    Join Date
    Aug 2008
    Location
    Selinsgrove, PA
    Posts
    79
    is that a TDR waterbox?

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FREE FLOW EXHAUST INSTALLATION INSTRUCTIONS.
    By RX951 in forum Yamaha How To & FAQs
    Replies: 34
    Last Post: 10-15-2009, 01:37 PM
  2. help thru hull exhaust install!!!
    By CarFanatic in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-20-2006, 10:37 PM
  3. Replies: 4
    Last Post: 07-07-2006, 10:14 AM
  4. rotax Power Flow exhaust install ??
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-18-2006, 10:14 AM
  5. PWC DEPTHFINDER INSTALL PICS
    By ABBOTT in forum Yamaha How To & FAQs
    Replies: 6
    Last Post: 03-28-2006, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •