Results 1 to 7 of 7
  1. #1

    Join Date
    Jul 2009
    Location
    Ft. Lauderdale, FL.
    Posts
    9

    2003 Polaris Virage I Fuel pump wont turn on

    emm will not turn on fuel pump when cranking. lanyard is installed. battery is fully charged. traced it back to emm brown wire does not ground out. Any ideas?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,576
    +1
    1,272
    Keep everything in one thread please

  3. #3

    Join Date
    Jul 2009
    Location
    Ft. Lauderdale, FL.
    Posts
    9

    2003 Polaris Virage I fuel pump wont turn on

    Brown wire has a pos+ charge coming straight out of emm which is same problem i had with original emm. I replaced emm and have the same problem. Is there anything else in the ski that would make the emm have a pos signal on the brown wire to the fuel pump. Or do i have another bad emm?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,576
    +1
    1,272
    Please, just keep all the replies in the other thread.

  5. #5

    Join Date
    Oct 2011
    Location
    Windsor, Connecticut, United States
    Posts
    3
    I have the same problem with my 2002 Polaris TXI. won't start and now no fuel pressure. I'm new to terms...what is the emm?

  6. #6
    engine management module I believe or something along those lines. Its the computer. To check the fuel pump you you connect jumper wires to it and see if it comes on. If it does you can then check to see if you have fuel pressure with pump running. If you dont, then the fuel pressure regulator has failed. You can either pull the tank and repair the stock regulator, or you can just cut into the return line and install the kawasaki regulator. If the pump runs when jumped and is producing fuel pressure, then the problem could be in your LR module or the computer itself.

  7. #7
    Resident electronics hacker UnityRacing's Avatar
    Join Date
    May 2007
    Location
    Va Beach, VA
    Posts
    1,425
    +1
    28
    Disconnect the fuel pump from the EMM. Unplug the electrical connection, THEN check the brown wire. The fuel pump may be faulty, and shorting out. Aside from that, DFI can check out your EMM and/or repair it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 polaris virage, died while riding & wont restart
    By burke in forum Polaris PWC Performance
    Replies: 5
    Last Post: 03-30-2017, 10:02 AM
  2. 1997 polaris slt 780 pump wont turn
    By theskindoctor in forum Polaris Tech Tips and Info
    Replies: 13
    Last Post: 06-29-2012, 11:12 AM
  3. 02 polaris virage txi fuel pump
    By rickybobby in forum Polaris Open Discussion
    Replies: 12
    Last Post: 03-18-2011, 03:01 PM
  4. 2000 GP1200R & 2003 Polaris Virage
    By Goliath in forum Yamaha 2 Stroke Skis
    Replies: 2
    Last Post: 07-13-2008, 09:45 PM
  5. 94 Polaris slt750 Tripple Fuel Pump
    By mkulczyckyj in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-20-2008, 10:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •