Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Do Work Son 05RXPnoob's Avatar
    Join Date
    Jul 2005
    Location
    Lake Chickamauga/ Chattanooga TN
    Posts
    958

    Got GPS and Riva Stage I and not impressed...

    After installing Riva Stage I on my ski, I thought I would get a GPS to see how fast my topend was...big dissapointment.

    Best I could do was 68.6...that was on no chop, pretty cool day-cluster said 84lake temp(but it always reads 84...?), 78 Etemp, and I weigh about 145#'s. Most of the runs where around high 67's and a couple 68's, but that was it. Also I dont have the prop installed yet because Riva has yet to send me the tool...but I do have the OPAS blocked off.

    Any ideas, comments? Im thinking about trying Hulks filling the rideplate holes trick, and trimming up the reverse bucket(even though I dont think its restricting any waterflow...).

    Jay


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,424
    +1
    176
    what rpm's are you seeing?

  3. #3
    Do Work Son 05RXPnoob's Avatar
    Join Date
    Jul 2005
    Location
    Lake Chickamauga/ Chattanooga TN
    Posts
    958
    Ohh yea, RPM's was another question I had...

    That 68.6 day I was seeing 7950 at the highest...and the most RPM's I ever seen was 8050 about a week before the mods and the temp felt the same, but mostly I see around 7900.

    Jay

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,424
    +1
    176
    have u checked your wear ring, and prop nose cone lately?

  5. #5
    Do Work Son 05RXPnoob's Avatar
    Join Date
    Jul 2005
    Location
    Lake Chickamauga/ Chattanooga TN
    Posts
    958
    Now that you mention it the wear ring has some grooves, gashes in it, but there not that bad-or to me their not? Cone looks like it always has...

    Jay

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,989
    +1
    1,900

    Re: Got GPS and Riva Stage I and not impressed...

    Quote Originally Posted by 05RXPnoob
    Also I dont have the prop installed
    There is your problem. When you install the new prop be sure to put a new wear ring in place.

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    oil level too high? grooved wear ring will contribute...

    the new prop will make a big difference, that can be a couple miles per hour right there that you are still missing.

  8. #8
    Do Work Son 05RXPnoob's Avatar
    Join Date
    Jul 2005
    Location
    Lake Chickamauga/ Chattanooga TN
    Posts
    958

    Re: Got GPS and Riva Stage I and not impressed...

    Quote Originally Posted by Green Hulk
    Quote Originally Posted by 05RXPnoob
    Also I dont have the prop installed
    There is your problem. When you install the new prop be sure to put a new wear ring in place.
    I was thinking that the prop would be the "biggest" peice of the kit, but shouldnt the air intake kit atleast raise the RPM's?

    Also would it be better to go with an new OEM wear ring-reuse the old one just reverse it, or a stainless peice as some of you guys are running?

    Oil level seems good last time I checked it.

    Jay

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,989
    +1
    1,900
    They say you get good results from flipping the wear ring. Give it a shot!

  10. #10
    Do Work Son 05RXPnoob's Avatar
    Join Date
    Jul 2005
    Location
    Lake Chickamauga/ Chattanooga TN
    Posts
    958
    Thanks for the input guys, yea I think I'll try reusing the wear ring...

    Jay

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXP Riva Stage One and more
    By CarFanatic in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 06-24-2008, 08:23 AM
  2. Riva Stage 3 and Rude Charger....
    By GeoRXT in forum 4-Tec Performance
    Replies: 28
    Last Post: 08-26-2007, 02:57 PM
  3. Check out these pics of the 07's and Riva stage 3
    By Green Hulk in forum 4-Tec Performance
    Replies: 19
    Last Post: 09-22-2006, 04:00 PM
  4. Replies: 4
    Last Post: 07-07-2006, 10:14 AM
  5. riva stage one and stage 2 impeller question
    By CarFanatic in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-19-2006, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •