Results 1 to 8 of 8

Thread: XL1200 Help

  1. #1

    Unhappy XL1200 Help

    Hey guys, I am needing some help. I took my 2000 Xl1200 out yesterday to see how it performed after the carb rebuild that was performed. Let me first state what was done to the ski. Removed the choke and installed a primer kit, R&D Power Plenum & rebuilt carbs and put all parts recommended by OsideBill for carbs with no chokes and after market FA’s. The ski ran fine for a few trips then all the sudden it just fell flat on it’s nose and turned off. I started it back up but quickly did the same thing. Being that I was in the middle of the lake with no traffic on it, I tried to restart it but all it did was clicked. Once I got it home I checked the battery and it had a full charge. I tried to start it again but it just clicked. After a couple of more tries it did start but sounds like crap. Anyone have any ideas on where I should start to trouble shoot? Thanks.


  2. #2

    Join Date
    Aug 2009
    Location
    LI, NY
    Posts
    344
    +1
    3
    Remove spark plugs and try to turn over. After cooling off does it turn over? Do compression test if it turns over.

  3. #3
    It does turn over now. I will be doing a compression test this evening. Thanks for the input.

  4. #4
    zx11rider's Avatar
    Join Date
    Jun 2009
    Location
    Cape Coral
    Posts
    1,132
    Quote Originally Posted by 00 XLT View Post
    It does turn over now. I will be doing a compression test this evening. Thanks for the input.
    Sorry to hear that mine did the same exact thing when it was stock the oil line had fallen off the #3 cylinder causing it to seize once it cooled it would start but run rough get a compression check right away did you go premix or are you still using the oil pump the lines get weak and fall off. Ron

  5. #5
    icky002's Avatar
    Join Date
    Oct 2008
    Location
    nj
    Posts
    151
    do the compression test and cross your fingers.

  6. #6
    Ron, I kept the oil injection for the mean time which may have proved to be a costly mistake. I did a compression test and the #3 cylinder wouldn't even give me a reading....time to rebuild. I will start taking things apart this weekend.

  7. #7

    Join Date
    Aug 2009
    Location
    LI, NY
    Posts
    344
    +1
    3

    Unhappy

    Sorry to hear that dude.

  8. #8
    zx11rider's Avatar
    Join Date
    Jun 2009
    Location
    Cape Coral
    Posts
    1,132
    Quote Originally Posted by 00 XLT View Post
    Ron, I kept the oil injection for the mean time which may have proved to be a costly mistake. I did a compression test and the #3 cylinder wouldn't even give me a reading....time to rebuild. I will start taking things apart this weekend.
    Yep get the exhaust off and see if the oil line came off mine was #3 as well when it was stock and get the oil block off plate for the next time let me know if the line came off thats what it sounds like.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rebuilding carbs on xl1200 help
    By Extrnoa in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-25-2014, 09:54 AM
  2. 98 XL1200 help
    By ButchB in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 04-10-2011, 05:30 PM
  3. HELP! XL1200 Ride plate/pump shoe brackets
    By bbealing in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-20-2008, 07:22 PM
  4. Need help with a 1999 XL1200
    By blu4ce in forum Yamaha Old School Skis
    Replies: 11
    Last Post: 06-10-2008, 10:01 AM
  5. '99 XL1200 Problems -HELP!!
    By wet one in forum Yamaha Open Discussion
    Replies: 14
    Last Post: 06-19-2007, 06:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •