Results 1 to 2 of 2
  1. #1

    Join Date
    Jul 2009
    Location
    on nc va border
    Posts
    75
    +1
    1

    Do ya have to hook up the steering sensor

    I'm installing a UMI steering system( of Chris Macc's old race boat,no b.s. it's autographed by him and Rachel) on my ultra and was wondering if the sensor has to be remounted. Will the ski send error codes or worse go into limp home mode. also does the beeper also have to be reconnected. I personally don't like how it gives the ski throttle, that's my job!


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,166
    +1
    602
    Quote Originally Posted by eazygoin View Post
    I'm installing a UMI steering system( of Chris Macc's old race boat,no b.s. it's autographed by him and Rachel) on my ultra and was wondering if the sensor has to be remounted. Will the ski send error codes or worse go into limp home mode. also does the beeper also have to be reconnected. I personally don't like how it gives the ski throttle, that's my job!
    can be left off with no Trouble codes

    but your off throttle wont work
    Not that it does massive difference anyway

    Waz

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil change question - do I need to warm up the machine before doing an oil change?
    By hotsoup in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-30-2014, 04:47 PM
  2. Do you have to seal the ride plate right away??
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 09-19-2007, 07:03 PM
  3. do i have to open the exhaust?
    By dettol in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-30-2007, 08:09 AM
  4. do i have to register in the yamaha forum also???????
    By rapidacceleration in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-04-2006, 10:14 AM
  5. Instaling my BOV do I have to use the middle notch????
    By Jrsrxp in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-22-2005, 07:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •