Results 1 to 7 of 7

Thread: LR-54 module

  1. #1
    Newbee PWC wrencher gregsauls's Avatar
    Join Date
    Nov 2009
    Location
    Texarkana,Tx
    Posts
    100

    LR-54 module

    Need an LR-54 module for my SLT-750-780 project. Got it all running but my module is out and limiting my revvvvs. Let me know what you got!

    Greg


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    If the LR-54 module is disconnected, it should not be affecting your RPM.

    Are you sure the Temp sender Tan wire is not shorted to ground?

  3. #3
    Newbee PWC wrencher gregsauls's Avatar
    Join Date
    Nov 2009
    Location
    Texarkana,Tx
    Posts
    100
    Quote Originally Posted by K447 View Post
    If the LR-54 module is disconnected, it should not be affecting your RPM.

    Are you sure the Temp sender Tan wire is not shorted to ground?
    Did the tests by the book. After testing oil, fuel and temp sensors to verify they were not causing the rpm limit (pulled each wire from board while running) none of them (pinks or browns/tans) eliminated the rpm limit after being pulled. Brown/tan lug on board wasn't shorted either. Fuel sender showed less than 3.1 volts and the tank is half full. MDF is not flashing red (hot, oil nor fuel)

    Only after pulling the gray wire from the LR-54 did the rpm's go past 4400. Sooooo, book flow chart says bad LR-54.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Contact John Zigler.

    I'm pretty sure he has one for you.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by gregsauls View Post
    ...LR-54 module... module is out and limiting my revvvvs...
    Quote Originally Posted by gregsauls View Post
    ...Only after pulling the gray wire from the LR-54 did the rpm's go past 4400.

    Sooooo, book flow chart says bad LR-54.
    I mis-understood what you meant by your module being 'out'

    I took it to mean you had unplugged it, and were still having an RPM limit issue...

  6. #6
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    Quote Originally Posted by xlint89 View Post
    Contact John Zigler.

    I'm pretty sure he has one for you.
    thanks kevin.

    yes, i have one here, 30.00 + s&h

    please send me an email, or call if i can help. ( just a FYI, ai have to leave early today, at about 3pm, and will not be back, but i will be in all day tomorrow, 9-5)

    thanks. zig

  7. #7
    Newbee PWC wrencher gregsauls's Avatar
    Join Date
    Nov 2009
    Location
    Texarkana,Tx
    Posts
    100

    Thanks!

    Got one on it's way. Thanks folks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts LR-52 module
    By ripcuda in forum Polaris Classifieds
    Replies: 0
    Last Post: 02-28-2015, 06:58 PM
  2. Replies: 4
    Last Post: 03-29-2014, 04:51 PM
  3. Replies: 4
    Last Post: 07-21-2013, 12:16 PM
  4. Replies: 4
    Last Post: 07-10-2012, 12:55 PM
  5. LR-54 Module for sale, brand new
    By Velislide in forum Polaris Classifieds
    Replies: 0
    Last Post: 04-24-2008, 09:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •