Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    big83bronco's Avatar
    Join Date
    May 2006
    Location
    Macon, GA
    Posts
    326

    BOOM!!!!!!!!!!!!!!!!!!!!!!!!

    WEll not exactly more like dead in the water. Ski was runnign good, water was really smooth. I was running about 66.6 mph (**Should of been sign #1**) THen all the sudden the ski dies. Stop let it sit a second, then it fires right back up and runs grea for another minute, then dies again. I immediately thoguth it was a sizure, so I got towed back in and found under the head what looks to be a dropped PV......... This is the second motor this summer! So frustrated. Any body got the parts to fix this laying around? Its hard ot see from teh pic but teh cyl that is hurt has a hole all the way through it, but the ring is still intact!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Head.jpg 
Views:	71 
Size:	808.4 KB 
ID:	7924   Click image for larger version. 

Name:	No1exhport.jpg 
Views:	72 
Size:	711.0 KB 
ID:	7925   Click image for larger version. 

Name:	No2.jpg 
Views:	68 
Size:	837.9 KB 
ID:	7926  


  2. #2
    JetSkiDaddy's Avatar
    Join Date
    May 2005
    Location
    Houston, TX
    Posts
    1,418
    +1
    4
    Damm power valves
    I got 6 good cylinders if ya need one, got 3 used pistons too.

  3. #3
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    I cant even start counting the skis that blew up this year. There has been alot of money going out in parts and labor.AMAZING but sad.

  4. #4
    big83bronco's Avatar
    Join Date
    May 2006
    Location
    Macon, GA
    Posts
    326

    Unhappy

    Yeah, tell me about it, this is my second motor!! Some of you may recognize this motor as Ben Herman's "Junkyard 1200". It really was a GREAT motor, my own damn fault for not going ahead and puttign the Wave Eaters in. I just kept forgetting to order them!

  5. #5

    Join Date
    Jul 2006
    Location
    Acworth, GA
    Posts
    157
    +1
    1
    Quote Originally Posted by big83bronco
    Yeah, tell me about it, this is my second motor!! Some of you may recognize this motor as Ben Herman's "Junkyard 1200". It really was a GREAT motor, my own damn fault for not going ahead and puttign the Wave Eaters in. I just kept forgetting to order them!
    Ugh... that seriously sucks. I feel your pain there... I just recently got mine back together after it blew up in March. At least you shouldn't have to split the cases.

  6. #6
    Quote Originally Posted by big83bronco
    Yeah, tell me about it, this is my second motor!! Some of you may recognize this motor as Ben Herman's "Junkyard 1200". It really was a GREAT motor, my own damn fault for not going ahead and puttign the Wave Eaters in. I just kept forgetting to order them!
    if your going to do the top end again order the r&d valves , i heard that they wont do that and they wont need the waveeater clips either ! im using the clips but if i did my top i'd switch over !

  7. #7
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    That Hurts!! I have been through three sets of cylinders in two skis this year. last year not a single problem one ski had less than 15 hours on newly bored cylinders with fresh pistons.

    OsideBill

  8. #8

    Valves

    I think the best way is to just get rid of the valves all together. I dropped a gas valve in July. Man they cause alot of trouble....

  9. #9

    Join Date
    Jan 2006
    Location
    Texas City, Texas
    Posts
    1,249
    +1
    15
    Was it detonation or a power valve or water in the cylinder from a leaking gasket? That piston and the head look awfuly dry and clean.

  10. #10
    steach's Avatar
    Join Date
    Dec 2005
    Location
    Rock Tavern, NY
    Posts
    3,174
    +1
    174
    Quote Originally Posted by OutlawGPR
    I think the best way is to just get rid of the valves all together. I dropped a gas valve in July. Man they cause alot of trouble....
    SeaDoo got something right.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sonic booms results
    By ChewsteR in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-20-2007, 09:22 PM
  2. Mudbug Sonic Boom Radar Testing
    By rossnemo in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 05-08-2007, 07:52 PM
  3. Sonic boom EFI settings
    By ChewsteR in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 04-28-2007, 01:35 PM
  4. Superjet Driveshaft went BOOM!
    By icerocket1286 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-10-2006, 09:44 PM
  5. Boom Boom stickem
    By JD 1 in forum 4-Tec Performance
    Replies: 39
    Last Post: 05-14-2006, 03:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •