Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Apr 2005
    Location
    Logan Township, NJ
    Posts
    280

    new 05 RXT NEED HELP

    Gentlemen and ladies

    I have a friend that just bought a new 05 RXT. It runs like crap from day one. THe dealer has since replaced the supercharger. The ski will only run about 7400RPM. I had him check the oil and it was well over a quart extra. He drained it and it seemed to run a little better, but never made it past 7600RPM's. THe dealer says that everything is fine. So this is the biggest problem...the ski always....ALWAYS...surges..... THe dealer is frigin clueless....I told him to check the knock sensor...but what else could it be. We need to figure this out!! THe ski hjas only 12 hours on it. Everything is stock. He says that it feels like it is running on 2 cyliners. Please give me lots of ideas...you could call me at work in the morning....856-339-3056 or post...but please lets help him...this is hisfirst 4 stroke..he has plenty of 2 strokes GTX's....traded one in for this little lemon.....thanks again for the input

    Peter


  2. #2
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    9,386
    +1
    629
    When my RXP oil was over filled it felt like it took an hour or so to get back its RPMS.
    Check his pump for damage to prop and wear ring.

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    sorry to hear about the ski... must be aggravating i can imagine. I have an RXT also, i can assure you it's a near indestructible ski, weird whats goin on with his. What dealer is workin on it and where are they located?

  4. #4

    Join Date
    Apr 2005
    Location
    Logan Township, NJ
    Posts
    280

    update......knock sensor info needed

    Well the dealer replaced the computer. The ski still runs bad. The ski has run bad from day 1. My friend took the ski out yesterday and the same thing. ABout 7500RPM's and then it just seems to go down from there. It also has the constant surging. I told him to have the dealer replace the knock sensor. The dealer said that there has never been a problem with a knock sensor and that the computer says that it is fine. So this dealer is a bozo. What I want to do is take the knock sensor from one of my RXP's and replace it with his. I need to know is this okay swapping from an RXP to a RXT? and most important...where is the knock sensor and what do I need to do to get to it. THanks again for the help and the phone calls.

    Peter

  5. #5
    how much does it surge? Does it surge from rough running to smooth running? Or is it just a surge in rpm.

    I know this is overly simple, but if it's running rough like it's missing on one or more cylinders, replace the plugs before you do anything else. You may just be suprised.

    I have had oem plugs go bad on both of my skis under the 15 hour mark on the RXP and under the 30 hour mark on the GTX SC. Almost exactly the same symptoms as your friends ski.

    When my RXP started acting up like that, I thought for sure that it was a problem with the ecu. But being a folower of the K.I.S.S. principal, I swapped out the plugs with a fresh set before I bothered trailering her over to the dealer. Cleared the problem right up. When the GTX acted up, I immediatly swapped out the plugs with a fresh set and it fixed that one also.

    BTW each of the plugs I pulled out looked perfectly normal and just the right color. So a visual inspection in this case was useless and the dealer wouldn't have bothered replacing them.

  6. #6
    way2fast's Avatar
    Join Date
    May 2005
    Location
    Melbourne Beach, FL
    Posts
    4,013
    +1
    3
    Thomas; A spark plug has no moving parts, if the electrode is not fouled or worn down and the porcelain isn't cracked, what could go wrong with a spark plug ?? Incorrect gap? Internal short due to faulty construction? If this were the case you would think it would show from day one.


    Richard

  7. #7
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,457
    +1
    256
    I would also start with the plugs for 12 dollars and 5 minutes you will know if it is not the plugs you will have an extra set I always start with the simple things

  8. #8
    sprchrgd89gt's Avatar
    Join Date
    May 2005
    Location
    Chi-Town
    Posts
    183
    Sounds like a vacuum leak , check all hose clamps from s/c intake and any other vacuum hoses you can find for cracks or dissconnections !! Just a thought i've seen race cars surge because of a small vacuum leak , even have caused irregular idle also check ground cble !

  9. #9

    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    128
    I just bought my new RXT 1 hr latter 7850 for an instant out of the box. I test ride the crap out of it before I bought. To many times I've ending up with crap. How maney Hrs are on it? It can be plugs my RXP eat them every 4-6 hrs of run time. If he loaded it up during break in coukd be the plugs.

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    Quote Originally Posted by Burnwater
    It can be plugs my RXP eat them every 4-6 hrs of run time. If he loaded it up during break in coukd be the plugs.
    WHAAAAAAAAA???

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New here...Need help on my 2008 RXT 255 Seadoo
    By Ricksraiders in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 06-07-2014, 09:59 PM
  2. New Guy Needs Help
    By BAM104 in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-27-2007, 02:23 AM
  3. Setting up new carbs...need help
    By IrishGpr05 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-28-2007, 12:51 PM
  4. new ski need help
    By bradgfh in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-02-2007, 02:27 PM
  5. New guy needs help...
    By Watdog in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 10-18-2006, 05:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •