Results 1 to 2 of 2
  1. #1
    gsxr800's Avatar
    Join Date
    Jan 2008
    Location
    Rivershit, Ct
    Posts
    116

    So did i screw up?

    I just realized when i fogged my motor on my 07 rxp i turned the motor over in drown mode with the plugs in place. Should i have done this with the plugs out? Does the fogging oil create a hydolock situation? Or is it fine because of the slow rotation.


  2. #2
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Quote Originally Posted by gsxr800 View Post
    I just realized when i fogged my motor on my 07 rxp i turned the motor over in drown mode with the plugs in place. Should i have done this with the plugs out? Does the fogging oil create a hydolock situation? Or is it fine because of the slow rotation.
    you should be fine, i did the same thing and just had my exhaust off and there fog oil all over inside

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Did i screw up, or is my dealers service writer being a dick
    By BLASTER 1 in forum Yamaha PWC Performance (4-stroke)
    Replies: 21
    Last Post: 04-13-2016, 11:26 AM
  2. did i screw this up
    By jeff12pv in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 02-20-2011, 12:17 PM
  3. Did I screw up!!!!
    By lashk in forum 2-Stroke Performance
    Replies: 10
    Last Post: 01-09-2010, 01:13 PM
  4. boy did i screw up
    By catchme in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-07-2007, 07:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •