Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    cckeong's Avatar
    Join Date
    Oct 2007
    Location
    NJ
    Posts
    135

    215 SC GTX Loss of Speed

    Please give some advise,I only can get this result RPM7250 60MPH (Full tank on Speedo)L85F E90F 160lb rider.
    I think it suppose RPM8000 and 68MPH.

    Below is my setup
    03 GTX SC LTD Engine upgrade to 04 215HP but with 03original Wiring Harness.
    XS IC,K&N Filter,New Wearing,New Plug,New Valve,good compression.New SC Shaft.Ferra valve.Stock Grate.


  2. #2

    Join Date
    Mar 2007
    Location
    Cairns Australia
    Posts
    234
    Check the slip in your Supercharger.

  3. #3
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    With that being an 03, does it have the plastic pump? Possibly wear ring damage?

  4. #4
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Do you have the 185 or 215 ECU? Check boost leaks too.

  5. #5
    cckeong's Avatar
    Join Date
    Oct 2007
    Location
    NJ
    Posts
    135
    SC no Slip,06 RXT pump with new wearing.215ECU what is Boost leak?

    I suspect the water box cause it's 185 type and the Filter in the manifold...

  6. #6
    remove the stock oem intake manifold filter element, install block-off kit, can increased boost pressure (+1lb)

  7. #7
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    It is probably SC or drivline related

    Double-check the slip on the SC and check for boost leaks (bad connections on air hoses to and from SC and XS IC)

    Check impeller for ding, dents and breaks

    Check wear ring for severe impeller scratches/wear, rips, tears, bends and melts.

    The 185 and 215 waterbox will not make a difference UNLESS it is plugged and not allowing the exahaust through it. The flame arrestor (filter in manifold) is not preventing that many RPMs.

    Maybe research what pump failure symptoms are.

  8. #8
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Quote Originally Posted by thomas loh View Post
    remove the stock oem intake manifold filter element, install block-off kit, can increased boost pressure (+1lb)
    Good idea, but it will not give him the missing 850 RPMs!

  9. #9
    jpeconsult's Avatar
    Join Date
    Jul 2007
    Location
    Pineville, LA
    Posts
    5,448
    +1
    1
    Is the engine running correctly? Does it douns normal...like it is running on all three cylinders?

    Brainstorming, here.

  10. #10
    what size impeller use??

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 GTX Lots of stuff.. loss of speed
    By Birdman in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-15-2010, 08:08 AM
  2. 2003 gtx sc intermittent loss of no 2 cylinder
    By csurt in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 01-13-2008, 06:23 AM
  3. Loss of speed and High Rpms
    By njgprider in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 09-02-2006, 11:35 AM
  4. Loss of speed and RPMs
    By NJ-Ski in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-21-2006, 10:34 AM
  5. Jerry - Loss of rpm - loss of speed
    By RXPDAVID in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-13-2005, 03:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •